summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorMarko Mäkelä <marko.makela@mariadb.com>2021-08-19 12:25:00 +0300
committerMarko Mäkelä <marko.makela@mariadb.com>2021-08-19 12:25:00 +0300
commitf3fcf5f45c9c09242bfb8762a88c26238458e4c2 (patch)
tree914f1a5d9bd38b9f9d09d0c39306c80c00e21842 /debian
parent475f69b98587c2a0842e3fcbfe515e4362ded973 (diff)
parent17980e35fafdf0b05c89c11ecafbea96e1cfc5e5 (diff)
downloadmariadb-git-f3fcf5f45c9c09242bfb8762a88c26238458e4c2.tar.gz
Merge 10.5 to 10.6
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/autobake-deb.sh20
-rwxr-xr-xdebian/rules28
2 files changed, 16 insertions, 32 deletions
diff --git a/debian/autobake-deb.sh b/debian/autobake-deb.sh
index 5e4beb1aa41..5a78c527e3c 100755
--- a/debian/autobake-deb.sh
+++ b/debian/autobake-deb.sh
@@ -17,29 +17,17 @@ set -e
# building the deb packages here.
export DEB_BUILD_OPTIONS="nocheck $DEB_BUILD_OPTIONS"
-# Take the files and part of control from MCS directory
-if [[ -d storage/columnstore/columnstore/debian ]]
-then
- cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
- echo >> debian/control
- cat storage/columnstore/columnstore/debian/control >> debian/control
-
- # ColumnStore is explicitly disabled in the native build, so allow it now
- # when build it when triggered by autobake-deb.sh
- sed '/-DPLUGIN_COLUMNSTORE=NO/d' -i debian/rules
-fi
-
# General CI optimizations to keep build output smaller
if [[ $TRAVIS ]] || [[ $GITLAB_CI ]]
then
# On both Travis and Gitlab the output log must stay under 4MB so make the
# build less verbose
- sed '/Add support for verbose builds/,/^$/d' -i debian/rules
-
# MCOL-4149: ColumnStore builds are so slow and big that they must be skipped on
# both Travis-CI and Gitlab-CI
- sed 's|$(CMAKEFLAGS)|$(CMAKEFLAGS) -DPLUGIN_COLUMNSTORE=NO|' -i debian/rules
- sed "/Package: mariadb-plugin-columnstore/,/^$/d" -i debian/control
+ sed -e '/Add support for verbose builds/,/^$/d' \
+ -e '/ColumnStore is part of the build/,/^$/d' \
+ -e 's|$(CMAKEFLAGS)|$(CMAKEFLAGS) -DPLUGIN_COLUMNSTORE=NO|' \
+ -i debian/rules
fi
# Don't build or try to put files in a package for selected plugins and components on Travis-CI
diff --git a/debian/rules b/debian/rules
index 123a0b9305e..03e8f280a63 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,11 +38,6 @@ else
NUMJOBS = 1
endif
-# RocksDB cannot build on 32-bit platforms
-ifeq (32,$(DEB_HOST_ARCH_BITS))
- CMAKEFLAGS += -DPLUGIN_ROCKSDB=NO
-endif
-
# Cross building requires stack direction instruction
ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
ifneq (,$(filter $(DEB_HOST_ARCH_CPU),alpha amd64 arm arm64 i386 ia64 m68k mips64el mipsel powerpc ppc64 ppc64el riscv64 s390x sh4 sparc64))
@@ -59,14 +54,6 @@ ifneq (,$(filter $(DEB_HOST_ARCH_CPU),amd64 arm64 ppc64el))
CMAKEFLAGS += -DWITH_PMEM=yes
endif
-# Add extra flag to avoid WolfSSL code crashing the entire mariadbd on s390x. This
-# can be removed once upstream has made the code s390x compatible, see
-# https://jira.mariadb.org/browse/MDEV-21705 and
-# https://github.com/wolfSSL/wolfssl/issues/2828
-ifeq ($(DEB_HOST_ARCH),s390x)
- CFLAGS += -DWC_NO_CACHE_RESISTANT
-endif
-
# Add support for verbose builds
MAKEFLAGS += VERBOSE=1
@@ -85,15 +72,25 @@ ifneq ($(DEB_BUILD_ARCH),$(DEB_HOST_ARCH))
dpkg-architecture -a$(DEB_BUILD_ARCH) -f -c dh_auto_configure --builddirectory=builddir-native
dh_auto_build --builddirectory=builddir-native -- import_executables
endif
+
+ # ColumnStore is part of the build
+ifneq (32,$(DEB_HOST_ARCH_BITS))
+ # Take the files and part of control from MCS directory
+ cp -v storage/columnstore/columnstore/debian/mariadb-plugin-columnstore.* debian/
+ # Don't include twice
+ grep -q '^Package: mariadb-plugin-columnstore$$' debian/control || \
+ ( echo && cat storage/columnstore/columnstore/debian/control ) >> debian/control
+endif
+
echo "server:Version=$(DEB_VERSION)" >> debian/substvars
- # Don't build ColumnStore as part of the native build, only build it when
- # triggered by autobake-deb.sh. Saves build time and disk space.
+ # RocksDB and Column Store cannot build on 32-bit platforms
PATH=$${MYSQL_BUILD_PATH:-"/usr/lib/ccache:/usr/local/bin:/usr/bin:/bin"} \
NO_UPDATE_BUILD_VERSION=1 \
dh_auto_configure --builddirectory=$(BUILDDIR) -- \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
$(CMAKEFLAGS) \
+ $(if $(findstring $(DEB_HOST_ARCH_BITS),32),-DPLUGIN_ROCKSDB=NO -DPLUGIN_COLUMNSTORE=NO) \
$(if $(filter $(DEB_BUILD_ARCH),$(DEB_HOST_ARCH)),,-DIMPORT_EXECUTABLES=$(CURDIR)/builddir-native/import_executables.cmake) \
-DCOMPILATION_COMMENT="mariadb.org binary distribution" \
-DMYSQL_SERVER_SUFFIX="-$(DEB_VERSION_REVISION)" \
@@ -102,7 +99,6 @@ endif
-DBUILD_CONFIG=mysql_release \
-DCONC_DEFAULT_CHARSET=utf8mb4 \
-DPLUGIN_AWS_KEY_MANAGEMENT=NO \
- -DPLUGIN_COLUMNSTORE=NO \
-DIGNORE_AIO_CHECK=YES \
-DWITH_URING=yes \
-DDEB=$(DEB_VENDOR)