summaryrefslogtreecommitdiff
path: root/extra/CMakeLists.txt
diff options
context:
space:
mode:
authorunknown <georg@lmy002.wdf.sap.corp>2006-08-31 19:52:42 +0200
committerunknown <georg@lmy002.wdf.sap.corp>2006-08-31 19:52:42 +0200
commit8f4477281eb5f110094927abe7dabd67c8525fc5 (patch)
tree1a7d7e96d4dcd302dbe513ad50a16ea05cb7ed16 /extra/CMakeLists.txt
parent085446b8c8de9154be2673efd7c8676ececd83ff (diff)
downloadmariadb-git-8f4477281eb5f110094927abe7dabd67c8525fc5.tar.gz
Additional files for cmake support
CMakeLists.txt: New BitKeeper file ``CMakeLists.txt'' bdb/CMakeLists.txt: New BitKeeper file ``bdb/CMakeLists.txt'' client/CMakeLists.txt: New BitKeeper file ``client/CMakeLists.txt'' dbug/CMakeLists.txt: New BitKeeper file ``dbug/CMakeLists.txt'' extra/CMakeLists.txt: New BitKeeper file ``extra/CMakeLists.txt'' extra/yassl/CMakeLists.txt: New BitKeeper file ``extra/yassl/CMakeLists.txt'' extra/yassl/taocrypt/CMakeLists.txt: New BitKeeper file ``extra/yassl/taocrypt/CMakeLists.txt'' heap/CMakeLists.txt: New BitKeeper file ``heap/CMakeLists.txt'' innobase/CMakeLists.txt: New BitKeeper file ``innobase/CMakeLists.txt'' libmysql/CMakeLists.txt: New BitKeeper file ``libmysql/CMakeLists.txt'' myisam/CMakeLists.txt: New BitKeeper file ``myisam/CMakeLists.txt'' myisammrg/CMakeLists.txt: New BitKeeper file ``myisammrg/CMakeLists.txt'' mysys/CMakeLists.txt: New BitKeeper file ``mysys/CMakeLists.txt'' regex/CMakeLists.txt: New BitKeeper file ``regex/CMakeLists.txt'' server-tools/CMakeLists.txt: New BitKeeper file ``server-tools/CMakeLists.txt'' server-tools/instance-manager/CMakeLists.txt: New BitKeeper file ``server-tools/instance-manager/CMakeLists.txt'' sql/CMakeLists.txt: New BitKeeper file ``sql/CMakeLists.txt'' sql/examples/CMakeLists.txt: New BitKeeper file ``sql/examples/CMakeLists.txt'' strings/CMakeLists.txt: New BitKeeper file ``strings/CMakeLists.txt'' tests/CMakeLists.txt: New BitKeeper file ``tests/CMakeLists.txt'' vio/CMakeLists.txt: New BitKeeper file ``vio/CMakeLists.txt'' win/Makefile.am: New BitKeeper file ``win/Makefile.am'' win/README: New BitKeeper file ``win/README'' win/build-vs71.bat: New BitKeeper file ``win/build-vs71.bat'' win/build-vs8.bat: New BitKeeper file ``win/build-vs8.bat'' win/build-vs8_x64.bat: New BitKeeper file ``win/build-vs8_x64.bat'' win/configure.js: New BitKeeper file ``win/configure.js'' zlib/CMakeLists.txt: New BitKeeper file ``zlib/CMakeLists.txt''
Diffstat (limited to 'extra/CMakeLists.txt')
-rwxr-xr-xextra/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/extra/CMakeLists.txt b/extra/CMakeLists.txt
new file mode 100755
index 00000000000..50e0f04eb14
--- /dev/null
+++ b/extra/CMakeLists.txt
@@ -0,0 +1,32 @@
+SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
+SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -DSAFEMALLOC -DSAFE_MUTEX")
+
+INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/include)
+
+ADD_EXECUTABLE(comp_err comp_err.c)
+TARGET_LINK_LIBRARIES(comp_err dbug mysys strings wsock32)
+
+GET_TARGET_PROPERTY(COMP_ERR_EXE comp_err LOCATION)
+
+ADD_CUSTOM_COMMAND(OUTPUT ${PROJECT_SOURCE_DIR}/include/mysqld_error.h
+ COMMAND ${COMP_ERR_EXE}
+ --charset=${PROJECT_SOURCE_DIR}/sql/share/charsets
+ --out-dir=${PROJECT_SOURCE_DIR}/sql/share/
+ --header_file=${PROJECT_SOURCE_DIR}/include/mysqld_error.h
+ --name_file=${PROJECT_SOURCE_DIR}/include/mysqld_ername.h
+ --state_file=${PROJECT_SOURCE_DIR}/include/sql_state.h
+ --in_file=${PROJECT_SOURCE_DIR}/sql/share/errmsg.txt
+ DEPENDS comp_err ${PROJECT_SOURCE_DIR}/sql/share/errmsg.txt)
+
+ADD_CUSTOM_TARGET(GenError
+ ALL
+ DEPENDS ${PROJECT_SOURCE_DIR}/include/mysqld_error.h)
+
+ADD_EXECUTABLE(my_print_defaults my_print_defaults.c)
+TARGET_LINK_LIBRARIES(my_print_defaults strings mysys dbug taocrypt odbc32 odbccp32 wsock32)
+
+ADD_EXECUTABLE(perror perror.c)
+TARGET_LINK_LIBRARIES(perror strings mysys dbug wsock32)
+
+ADD_EXECUTABLE(replace replace.c)
+TARGET_LINK_LIBRARIES(replace strings mysys dbug wsock32)