summaryrefslogtreecommitdiff
path: root/extra/CMakeLists.txt
diff options
context:
space:
mode:
authorJan Lindström <jan.lindstrom@mariadb.com>2017-01-03 14:35:08 +0200
committerJan Lindström <jan.lindstrom@mariadb.com>2017-01-03 14:36:31 +0200
commita0d396fd3f5f86e09f602ac9f76b8d9f2e739221 (patch)
tree14ed5f979a7fd3a397137a5a260a6865cddab589 /extra/CMakeLists.txt
parent8a04b8cadedb4b7388379a30b7d7211a2b607bfe (diff)
downloadmariadb-git-a0d396fd3f5f86e09f602ac9f76b8d9f2e739221.tar.gz
MDEV-11684: post-10.1-merge fixes
10.1 is merged into 10.2 now. Two issues are left to fix: (1) encryption.innochecksum test (2) read_page0 vs page_0_crypt_read (1) innochecksum tool did not compile after merge because buf_page_is_corrupted uses fil_crypt_t that has been changed. extra/CMakeLists.txt: Added fil/fil0crypt.cc as dependency as we need to use fil_crypt_verify_checksum for encrypted pages. innochecksum.cc: If we think page is encrypted i.e. FIL_PAGE_FILE_FLUSH_LSN_OR_KEY_VERSION != 0 we call fil_crypt_verify_checksum() function to compare calculated checksum to stored checksum calculated after encryption (this is stored on different offset i.e. FIL_PAGE_FILE_FLUSH_LSN_OR_KEY_VERSION + 4). If checksum does not match we call normal buf_page_is_corrupted to compare calculated checksum to stored checksum. fil0crypt.cc: add #ifdef UNIV_INNOCHECKSUM to be able to compile this file for innochecksum tool. (2) read_page0 is not needed and thus removed.
Diffstat (limited to 'extra/CMakeLists.txt')
-rw-r--r--extra/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/extra/CMakeLists.txt b/extra/CMakeLists.txt
index ee696c156f9..480cd6e7fbb 100644
--- a/extra/CMakeLists.txt
+++ b/extra/CMakeLists.txt
@@ -80,6 +80,7 @@ IF(WITH_INNOBASE_STORAGE_ENGINE OR WITH_XTRADB_STORAGE_ENGINE)
../storage/innobase/buf/buf0buf.cc
../storage/innobase/page/page0zip.cc
../storage/innobase/os/os0file.cc
+ ../storage/innobase/fil/fil0crypt.cc
)