summaryrefslogtreecommitdiff
path: root/extra/Makefile.am
diff options
context:
space:
mode:
authorunknown <serg@serg.mylan>2006-04-12 14:08:24 +0200
committerunknown <serg@serg.mylan>2006-04-12 14:08:24 +0200
commitc566f9a25f53ea88ef75d2f4d6e8c6f61745b3e7 (patch)
tree46aa796924bcff90935d9149ffb0d65ac7c6ae61 /extra/Makefile.am
parentef1ec197449dbfc00f64834af4564021368ac765 (diff)
downloadmariadb-git-c566f9a25f53ea88ef75d2f4d6e8c6f61745b3e7.tar.gz
fixes for 'make dist' and 'make distcheck'
BUILD/compile-dist: fixes for 'make dist' and 'make distcheck' include yassl in "dist" Makefile.am: fixes for 'make dist' and 'make distcheck' remove double-listing of everything in SUBDIRS and DIST_SUBDIRS remove @yassl_dir@, it belongs to extra/Makefile.am specify --basedir for mysql_install_db, in case builddir (where mysql_install_db is) differs from srcdir (where mysql_fix_privilege_tables.sql is) config/ac-macros/yassl.m4: fixes for 'make dist' and 'make distcheck' create Makefile's only if yassl is used yassl_dir must not include / config/ac-macros/zlib.m4: fixes for 'make dist' and 'make distcheck' create Makefile only if zlib is used configure.in: fixes for 'make dist' and 'make distcheck' create Makefile only if a feature is enabled storage engine dirs must not include / automatically disable readline/libedit/sql-bench if source dir is missing extra/Makefile.am: fixes for 'make dist' and 'make distcheck' remove SUBDIR/DIST_SUBDIR hack libmysql_r/Makefile.am: fixes for 'make dist' and 'make distcheck' when symlinking all files from libmysql/ take into account that srcdir != builddir libmysqld/Makefile.am: fixes for 'make dist' and 'make distcheck' remove fragile promiscuous search for object files if .o file is not where we look for it - extract it from the library mysql-test/ndb/Makefile.am: fixes for 'make dist' and 'make distcheck' ndbcluster script is not a "source" don't forget to cleanup plugin/Makefile.am: fixes for 'make dist' and 'make distcheck' include plugin/fulltext/configure.in template in the distribution storage/Makefile.am: fixes for 'make dist' and 'make distcheck' remove SUBDIRS/DIST_SUBDIRS hack storage/ndb/Makefile.am: fixes for 'make dist' and 'make distcheck' force common.mk.am out of DIST_COMMON (which is otherwise an auto-generated list of Makefile's sources) because it's listed indirectly in EXTRA_DIST, and with bk -r get, a file cannot be copied twice.
Diffstat (limited to 'extra/Makefile.am')
-rw-r--r--extra/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/extra/Makefile.am b/extra/Makefile.am
index 0aaa8c4d127..4b483128439 100644
--- a/extra/Makefile.am
+++ b/extra/Makefile.am
@@ -23,10 +23,7 @@ BUILT_SOURCES= $(top_builddir)/include/mysqld_error.h \
$(top_builddir)/include/mysqld_ername.h
pkginclude_HEADERS= $(BUILT_SOURCES)
CLEANFILES = $(BUILT_SOURCES)
-# We never use SUBDIRS here, but needed for automake 1.6.3
-# to generate code to handle DIST_SUBDIRS
-SUBDIRS=
-DIST_SUBDIRS= yassl
+SUBDIRS = @yassl_dir@
# This will build mysqld_error.h and sql_state.h
$(top_builddir)/include/mysqld_error.h: comp_err$(EXEEXT)