summaryrefslogtreecommitdiff
path: root/extra/Makefile.am
diff options
context:
space:
mode:
authorJoerg Bruehe <joerg@mysql.com>2008-08-25 21:07:41 +0200
committerJoerg Bruehe <joerg@mysql.com>2008-08-25 21:07:41 +0200
commitff3d230a03a69330d30ccbb43ce8550cdd6536d4 (patch)
tree1b792179af0db813530aea4109904b7cfdf78065 /extra/Makefile.am
parenta0768d32c24b2548a47dbd99aa00d53c5019220d (diff)
downloadmariadb-git-ff3d230a03a69330d30ccbb43ce8550cdd6536d4.tar.gz
Bug#37098 Get rid of "Installed (but unpackaged)" files in the RPM build
Mostly, this affected files (programs, scripts, and manual pages) which got built during a RPM build but were not listed in the appropriate "%files" section of the "spec" file. This is fixed now, they are added. To make this consistent, this patch also makes the build of "innochecksum" (and its inclusion in a tar.gz or other package) depend on whether InnoDB is configured in the build. Also, some tools to create Windows packages are irrelevant in any binary Unix package (not the sources !), and so they are deleted before packaging.
Diffstat (limited to 'extra/Makefile.am')
-rw-r--r--extra/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/extra/Makefile.am b/extra/Makefile.am
index 6eac67e2979..16567f8d613 100644
--- a/extra/Makefile.am
+++ b/extra/Makefile.am
@@ -45,7 +45,12 @@ $(top_builddir)/include/mysqld_ername.h: $(top_builddir)/include/mysqld_error.h
$(top_builddir)/include/sql_state.h: $(top_builddir)/include/mysqld_error.h
bin_PROGRAMS = replace comp_err perror resolveip my_print_defaults \
- resolve_stack_dump mysql_waitpid innochecksum
+ resolve_stack_dump mysql_waitpid
+# "innochecksum" should be switched
+if BUILD_INNODB_TOOLS
+bin_PROGRAMS += innochecksum
+endif
+
noinst_PROGRAMS = charset2html
EXTRA_DIST = CMakeLists.txt