summaryrefslogtreecommitdiff
path: root/extra/mariabackup/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <wlad@mariadb.com>2017-04-19 13:09:03 +0000
committerSergei Golubchik <serg@mariadb.org>2017-04-27 19:12:42 +0200
commitecb25df21b2cc9bcbb038dd9b82b8469acd18fd9 (patch)
tree08eba6fd38ecb81d73570371ba213a958299abc3 /extra/mariabackup/CMakeLists.txt
parentc8ac0244a843252d59985ad270cad2f074aebfb4 (diff)
downloadmariadb-git-ecb25df21b2cc9bcbb038dd9b82b8469acd18fd9.tar.gz
Xtrabackup 2.3.8
Diffstat (limited to 'extra/mariabackup/CMakeLists.txt')
-rw-r--r--extra/mariabackup/CMakeLists.txt15
1 files changed, 7 insertions, 8 deletions
diff --git a/extra/mariabackup/CMakeLists.txt b/extra/mariabackup/CMakeLists.txt
index 6f5a17d3614..693082b765a 100644
--- a/extra/mariabackup/CMakeLists.txt
+++ b/extra/mariabackup/CMakeLists.txt
@@ -1,14 +1,14 @@
-# Copyright (c) 2013 Percona LLC and/or its affiliates.
+# Copyright (c) 2013, 2017 Percona LLC and/or its affiliates.
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
# the Free Software Foundation; version 2 of the License.
-
+#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
# GNU General Public License for more details.
-
+#
# You should have received a copy of the GNU General Public License
# along with this program; if not, write to the Free Software
# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA
@@ -129,6 +129,7 @@ INCLUDE_DIRECTORIES(
${CMAKE_SOURCE_DIR}/sql
${CMAKE_CURRENT_SOURCE_DIR}/quicklz
${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_SOURCE_DIR}/crc
)
IF(NOT HAVE_SYSTEM_REGEX)
@@ -156,7 +157,6 @@ MYSQL_ADD_EXECUTABLE(mariabackup
${DS_ARCHIVE_SOURCE}
ds_buffer.c
ds_compress.c
- ds_encrypt.c
ds_local.c
ds_stdout.c
ds_tmpfile.c
@@ -166,8 +166,6 @@ MYSQL_ADD_EXECUTABLE(mariabackup
read_filt.cc
write_filt.cc
wsrep.cc
- xbcrypt_common.c
- xbcrypt_write.c
xbstream_write.c
backup_mysql.cc
backup_copy.cc
@@ -181,9 +179,10 @@ MYSQL_ADD_EXECUTABLE(mariabackup
# Export all symbols on Unix, for better crash callstacks
SET_TARGET_PROPERTIES(mariabackup PROPERTIES ENABLE_EXPORTS TRUE)
+ADD_SUBDIRECTORY(crc)
-TARGET_LINK_LIBRARIES(mariabackup sql)
+TARGET_LINK_LIBRARIES(mariabackup sql crc)
IF(NOT HAVE_SYSTEM_REGEX)
TARGET_LINK_LIBRARIES(mariabackup pcreposix)
@@ -201,13 +200,13 @@ MYSQL_ADD_EXECUTABLE(mbstream
xbstream.c
xbstream_read.c
xbstream_write.c
-
COMPONENT backup
)
TARGET_LINK_LIBRARIES(mbstream
mysys
+ crc
)
IF(MSVC)