summaryrefslogtreecommitdiff
path: root/extra/yassl/testsuite/Makefile.am
diff options
context:
space:
mode:
authorDavi Arnaut <Davi.Arnaut@Sun.COM>2010-06-08 18:14:18 -0300
committerDavi Arnaut <Davi.Arnaut@Sun.COM>2010-06-08 18:14:18 -0300
commit75a18e24fa72cca07254cbabd119b944c0ef989d (patch)
tree0699584297a9aa3c81ff88503dfb377f2d99610f /extra/yassl/testsuite/Makefile.am
parente484e89d3df80e5a67f3eeac71e7c5ec1b081513 (diff)
parent51e90dc79e5b3847a8b1fdf69b8207864ff2f7c8 (diff)
downloadmariadb-git-75a18e24fa72cca07254cbabd119b944c0ef989d.tar.gz
Merge of mysql-5.0-bugteam into mysql-5.1-bugteam.
config/ac-macros/ssl.m4: Enable yaSSL thread safety if linking with the server or a thread safe client library. Avoids building a thread safe yaSSL when only building a non-thread safe client library.
Diffstat (limited to 'extra/yassl/testsuite/Makefile.am')
-rw-r--r--extra/yassl/testsuite/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/extra/yassl/testsuite/Makefile.am b/extra/yassl/testsuite/Makefile.am
index cae34e7bbc0..e626b1822ec 100644
--- a/extra/yassl/testsuite/Makefile.am
+++ b/extra/yassl/testsuite/Makefile.am
@@ -4,7 +4,7 @@ testsuite_SOURCES = testsuite.cpp ../taocrypt/test/test.cpp \
../examples/client/client.cpp ../examples/server/server.cpp \
../examples/echoclient/echoclient.cpp \
../examples/echoserver/echoserver.cpp
-testsuite_CXXFLAGS = -DYASSL_PURE_C -DYASSL_PREFIX -DNO_MAIN_DRIVER
+testsuite_CXXFLAGS = -DYASSL_PURE_C -DYASSL_PREFIX -DNO_MAIN_DRIVER @yassl_thread_cxxflags@
testsuite_LDADD = $(top_builddir)/extra/yassl/src/libyassl.la \
$(top_builddir)/extra/yassl/taocrypt/src/libtaocrypt.la
EXTRA_DIST = testsuite.dsp test.hpp input quit make.bat