summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2006-11-03 14:40:52 +0100
committerunknown <msvensson@neptunus.(none)>2006-11-03 14:40:52 +0100
commit7bc532ae636951f49e3c3e9c6a556a9410366f97 (patch)
treef4b987688c9ab7bd121b2fb04366512b9517b69a /include/Makefile.am
parent75ed6f1a3ba3e908d7feaf5f1fd658ff7e4309f3 (diff)
parentcb404c2dcfd7da9bc83ed1c037b12904c3ff9e22 (diff)
downloadmariadb-git-7bc532ae636951f49e3c3e9c6a556a9410366f97.tar.gz
Merge neptunus.(none):/home/msvensson/mysql/mysql-5.0-maint
into neptunus.(none):/home/msvensson/mysql/mysql-5.1-new-maint client/mysql.cc: Auto merged mysql-test/lib/mtr_misc.pl: Auto merged mysql-test/r/innodb_mysql.result: Auto merged mysql-test/r/mysql.result: Auto merged mysql-test/r/ps.result: Auto merged mysql-test/r/view.result: Auto merged mysql-test/t/ctype_utf8.test: Auto merged mysql-test/t/im_daemon_life_cycle.imtest: Auto merged mysql-test/t/mysql.test: Auto merged mysql-test/t/ps.test: Auto merged mysql-test/t/sp-error.test: Auto merged include/mysql_h.ic: Auto merged mysql-test/include/mix1.inc: Auto merged mysql-test/t/sp.test: Auto merged mysql-test/t/view.test: Auto merged mysys/my_lock.c: Auto merged sql/handler.cc: Auto merged sql/item_func.cc: Auto merged sql/mysqld.cc: Auto merged sql/set_var.cc: Auto merged sql/sp.cc: Auto merged sql/sql_class.h: Auto merged sql/sql_delete.cc: Auto merged sql/sql_lex.cc: Auto merged sql/sql_lex.h: Auto merged sql/sql_parse.cc: Auto merged sql/sql_prepare.cc: Auto merged sql/sql_select.cc: Auto merged sql/sql_table.cc: Auto merged sql/sql_trigger.cc: Auto merged sql/sql_union.cc: Auto merged sql/sql_view.cc: Auto merged sql/sql_yacc.yy: Auto merged sql/table.cc: Auto merged storage/innobase/handler/ha_innodb.cc: Auto merged tests/mysql_client_test.c: Auto merged mysql-test/mysql-test-run.pl: Use remote include/Makefile.am: Manual merge
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am26
1 files changed, 10 insertions, 16 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index b46e1a8402c..3faa25c4bb9 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -15,7 +15,7 @@
# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA
-BUILT_SOURCES = mysql_version.h my_config.h mysql_h.ic
+BUILT_SOURCES = mysql_version.h my_config.h abi_check
pkginclude_HEADERS = my_dbug.h m_string.h my_sys.h my_list.h my_xml.h \
mysql.h mysql_com.h mysql_embed.h \
my_semaphore.h my_pthread.h my_no_pthread.h \
@@ -38,6 +38,8 @@ noinst_HEADERS = config-win.h config-netware.h \
# Remove built files and the symlinked directories
CLEANFILES = $(BUILT_SOURCES) readline openssl
+EXTRA_DIST = mysql_h.ic
+
# Some include files that may be moved and patched by configure
DISTCLEANFILES = sched.h $(CLEANFILES)
@@ -58,25 +60,17 @@ dist-hook:
# Rules for checking that ABI has not changed
#
-# Create a icheck file for mysql.h
-mysql_h.ic: mysql.h mysql_version.h mysql_com.h mysql_time.h my_list.h \
- my_alloc.h typelib.h
- @set -x; \
- if [ @ICHECK@ != no ] ; then \
- @ICHECK@ --canonify --skip-from-re /usr/ -o $@ mysql.h; \
- else \
- touch $@; \
- fi;
-
-# Compare the icheck file to the reference
-check_abi: mysql_h.ic
+# Create a icheck file and compare it to the reference
+abi_check: mysql.h mysql_version.h mysql_com.h mysql_time.h my_list.h \
+ my_alloc.h typelib.h
@set -ex; \
if [ @ICHECK@ != no ] ; then \
- @ICHECK@ --compare mysql_h.ic mysql_h_abi.ic; \
+ @ICHECK@ --canonify --skip-from-re /usr/ -o $@.ic mysql.h; \
+ @ICHECK@ --compare mysql_h.ic $@.ic; \
fi; \
- touch check_abi;
+ touch abi_check;
-#all: check_abi
+#all: abi_check
# Don't update the files from bitkeeper