summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorMarc Alff <marc.alff@sun.com>2009-11-30 17:49:15 -0700
committerMarc Alff <marc.alff@sun.com>2009-11-30 17:49:15 -0700
commitf2d67abbc0fe05d0b97a63127ffc7f85c892cf98 (patch)
tree60c7ded488b2fdc27e6b1d0de6f621cf4503e7dd /include/Makefile.am
parent3c11750e363da6e1017d5bc86e9e7e03b2c4e101 (diff)
downloadmariadb-git-f2d67abbc0fe05d0b97a63127ffc7f85c892cf98.tar.gz
WL#2360 Performance schema
Part 1: Instrumentation interface
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index fff162474a5..579eff1afad 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright (C) 2000-2006 MySQL AB
+# Copyright (C) 2000-2006 MySQL AB, 2009 Sun Microsystems, Inc
#
# This library is free software; you can redistribute it and/or
# modify it under the terms of the GNU Library General Public
@@ -24,6 +24,8 @@ pkginclude_HEADERS = $(HEADERS_ABI) my_dbug.h m_string.h my_sys.h \
my_xml.h mysql_embed.h mysql/services.h \
mysql/service_my_snprintf.h mysql/service_thd_alloc.h \
my_pthread.h my_no_pthread.h \
+ mysql/psi/psi.h mysql/psi/mysql_thread.h \
+ mysql/psi/mysql_file.h \
decimal.h errmsg.h my_global.h my_net.h \
my_getopt.h sslopt-longopts.h my_dir.h \
sslopt-vars.h sslopt-case.h sql_common.h keycache.h \
@@ -38,13 +40,15 @@ noinst_HEADERS = config-win.h config-netware.h lf.h my_bit.h \
my_aes.h my_tree.h my_trie.h hash.h thr_alarm.h \
thr_lock.h t_ctype.h violite.h my_md5.h base64.h \
my_handler.h my_time.h service_versions.h \
- my_rdtsc.h \
+ my_rdtsc.h mysql/psi/psi_abi_v1.h mysql/psi/psi_abi_v2.h \
my_vle.h my_user.h my_atomic.h atomic/nolock.h \
atomic/rwlock.h atomic/x86-gcc.h atomic/generic-msvc.h \
atomic/gcc_builtins.h my_libwrap.h my_stacktrace.h \
atomic/solaris.h
-EXTRA_DIST = mysql.h.pp mysql/plugin.h.pp probes_mysql.d.base
+EXTRA_DIST = mysql.h.pp mysql/plugin.h.pp probes_mysql.d.base \
+ mysql/psi/psi_abi_v1.h.pp \
+ mysql/psi/psi_abi_v2.h.pp
# Remove built files and the symlinked directories
CLEANFILES = $(BUILT_SOURCES) readline openssl probes_mysql.d probes_mysql_nodtrace.h