summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2002-05-03 12:31:25 +0200
committerunknown <lenz@mysql.com>2002-05-03 12:31:25 +0200
commit7c510b93c64773b609b97f04ae2d19c84b88045b (patch)
treef018e0ba3a16dbef55c7195250c190640678514d /include/Makefile.am
parent3bf08c41b2451475ea4f9676c36c151ef567abc7 (diff)
downloadmariadb-git-7c510b93c64773b609b97f04ae2d19c84b88045b.tar.gz
Reworked the RPM spec file and added several fixes to make the
build scripts work again. BUILD/compile-pentium-max: Added "--with-embedded-server" to have the libmysqld files included in the source distribution when using "make dist" Build-tools/Do-linux-build: Only use the "--with-other-libc" parameter, if another libc actually exists, since this will also force static linking, which does not work together with OpenSSL Makefile.am: Removed hard-coded file name for TAR, let configure do this instead (many systems actually ship GNU tar installed as "tar" instead of "gtar") configure.in: Added check for GNU tar named "gtar", fall back to "tar" if "gtar" was not found (and hope, that it's a GNU tar as well - this should probably be checked more properly) include/Makefile.am: Added "my_semaphore.h" to pkginclude_HEADERS since it was missing from the distribution strings/Makefile.am: Added "longlong2str.c" since it was missing from the distribution support-files/mysql.server.sh: Added LSB-compatible header info to make init script more portable support-files/mysql.spec.sh: - Use more RPM macros (e.g. infodir, mandir) to make the spec file more portable - reorganized the installation of documentation files: let RPM take care of this - reorganized the file list: actually install man pages along with the binaries of the respective subpackage - don't include libmysqld.a in the devel subpackage as well, if we have a special "embedded" subpackage - reworked the package descriptions
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 0745029a41d..1de98a07ef0 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -18,7 +18,7 @@
BUILT_SOURCES = mysql_version.h m_ctype.h my_config.h
pkginclude_HEADERS = dbug.h m_string.h my_sys.h my_list.h \
mysql.h mysql_com.h mysqld_error.h mysql_embed.h \
- my_pthread.h my_no_pthread.h raid.h errmsg.h \
+ my_semaphore.h my_pthread.h my_no_pthread.h raid.h errmsg.h \
my_global.h my_net.h my_alloc.h\
sslopt-case.h sslopt-longopts.h sslopt-usage.h \
sslopt-vars.h $(BUILT_SOURCES)