summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <vva@eagle.mysql.r18.ru>2003-01-18 20:28:48 +0400
committerunknown <vva@eagle.mysql.r18.ru>2003-01-18 20:28:48 +0400
commit316029ab011dd51d2a652a76a4a72a633b9eb938 (patch)
tree5c0247f2c0a6adbb61acd182e5def92ef978df93 /include/Makefile.am
parentf4574b691ec23446d2df2bd3e1790647ecd05728 (diff)
downloadmariadb-git-316029ab011dd51d2a652a76a4a72a633b9eb938.tar.gz
changes for readline/libedit configuration
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 652278e8a80..e197cee4cde 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -37,16 +37,25 @@ SUPERCLEANFILES = mysql_version.h my_config.h
# Some include files that may be moved and patched by configure
DISTCLEANFILES = sched.h
+clean:
+ $(RM) -f readline/*
+distclean:
+ $(RM) -f readline/*
+
all-local: my_config.h
# Since we include my_config.h it better exist from the beginning
link_sources:
$(CP) ../config.h my_config.h
+ $(RM) -f readline/*
+ @readline_h_ln_cmd@
# Keep automake happy
my_config.h: ../config.h
$(CP) ../config.h my_config.h
+ $(RM) -f readline/*
+ @readline_h_ln_cmd@
# These files should not be included in distributions since they are
# generated by configure from the .h.in files