summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorMikael Ronstrom <mikael@mysql.com>2009-02-21 09:12:08 +0100
committerMikael Ronstrom <mikael@mysql.com>2009-02-21 09:12:08 +0100
commit6ba903ad027399f67e8758dd14a6559b36af56ef (patch)
tree4a1057474f64b5e28316aef900b0d983283a8142 /include/Makefile.am
parented94b2008ef734e548173366bb8f045bdd122c81 (diff)
downloadmariadb-git-6ba903ad027399f67e8758dd14a6559b36af56ef.tar.gz
dtrace_sources also needed for non-DTrace builds
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 0bf4f70d3a4..8163f41e09e 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -69,6 +69,12 @@ my_config.h: config.h
dist-hook:
$(RM) -f $(distdir)/mysql_version.h $(distdir)/my_config.h
+dtrace_sources:
+ if ! test -f probes_mysql.d ; then \
+ $(CP) -f $(top_srcdir)/include/probes_mysql.d probes_mysql.d; \
+ fi
+ echo timestamp > dtrace_sources
+
DTRACEPROVIDER = probes_mysql.d
if HAVE_DTRACE
BUILT_SOURCES += probes_mysql_dtrace.h
@@ -78,12 +84,6 @@ CLEANFILES += probes_mysql_dtrace.h
# then we copy the probes from the source location and use that
# If we are building in the same directory as the source, we do not copy
-dtrace_sources:
- if ! test -f probes_mysql.d ; then \
- $(CP) -f $(top_srcdir)/include/probes_mysql.d probes_mysql.d; \
- fi
- echo timestamp > dtrace_sources
-
probes_mysql_dtrace.h: $(DTRACEPROVIDER)
$(DTRACE) $(DTRACEFLAGS) -h -s $(DTRACEPROVIDER) -o $@
endif