summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/kent-amd64.(none)>2007-07-30 21:09:45 +0200
committerunknown <kent@mysql.com/kent-amd64.(none)>2007-07-30 21:09:45 +0200
commit16ff419b8ae86ccbf017d19ee00141e3e1c05988 (patch)
treed7889999d2852a9bed51f043da21bf534596a6c2 /include/Makefile.am
parentc7e8135dfdef6502c8e310a77ae1b986fcdcbffd (diff)
downloadmariadb-git-16ff419b8ae86ccbf017d19ee00141e3e1c05988.tar.gz
Generate "config.h" directly into the "include" directory, later copied
to "my_config.h". Not to pollute the top directory, and to get more control over what is included. Made the include path for "libedit" pick up its own "config.h" first. config/ac-macros/misc.m4: aclocal in automake 1.8 can't handle AC_REQUIRE on a user macro defined in the same included file. cmd-line-utils/libedit/Makefile.am: Changed include path so that current directory is taken first, as there is a "config.h" there with the same name as the one in top "include". configure.in: Generate "config.h" directly into "include", don't pollute top directory include/Makefile.am: Copy "config.h" from current directory to "my_config.h", added note in the make file why there are two identical files with different name. scripts/make_binary_distribution.sh: Removed copy of "config.h" from top directory, it is in "include" in a source tree.
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 2cd72052a15..c856b6398fe 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -49,8 +49,11 @@ link_sources:
@readline_h_ln_cmd@
@yassl_h_ln_cmd@
-my_config.h: ../config.h
- $(CP) ../config.h my_config.h
+# We want both "my_config.h" and "config.h" that are identical, as
+# MySQL sources assumes the name "my_config.h", and 3rd party sources
+# assumes the name "config.h".
+my_config.h: config.h
+ $(CP) config.h my_config.h
# These files should not be included in distributions since they are
# generated by configure from the .h.in files