summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authormonty@donna.mysql.com <>2001-01-21 16:30:16 +0200
committermonty@donna.mysql.com <>2001-01-21 16:30:16 +0200
commit62771338ca94eee0dfd23a2d5c2fab0269ff1508 (patch)
treec772f489364087df96cf8f0582915a11ba82ae54 /include/Makefile.am
parentefb0dad5a8889ea8f08fb4d9493e221b18a610e1 (diff)
downloadmariadb-git-62771338ca94eee0dfd23a2d5c2fab0269ff1508.tar.gz
Changes for --with-server-suffix
Fixed mutex bug in logging (crash on windows when doing SET PASSWORD=) Changed MERGE tables to not use FILE
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 17d9c95216c..0cd749aea8a 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -15,7 +15,7 @@
# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA
-BUILT_SOURCES = mysql_version.h m_ctype.h
+BUILT_SOURCES = mysql_version.h m_ctype.h my_config.h
pkginclude_HEADERS = dbug.h m_string.h my_sys.h mysql.h mysql_com.h \
mysqld_error.h my_list.h \
my_pthread.h my_no_pthread.h raid.h errmsg.h \
@@ -43,6 +43,11 @@ all-local: my_global.h my_config.h
link_sources:
$(CP) ../config.h my_config.h
+# Keep automake happy
+
+my_config.h: ../config.h
+ $(CP) ../config.h my_config.h
+
# This should be changed in the source and removed.
my_global.h: global.h
$(RM) -f my_global.h