summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <serg@serg.mylan>2004-04-26 13:27:23 +0200
committerunknown <serg@serg.mylan>2004-04-26 13:27:23 +0200
commit6c01a22dbdaf478720c444eea74d2c11fa21e9d7 (patch)
tree9b7c83462af788f5a576b0a13dfbfdac73ce7274 /include/Makefile.am
parent39ef383cc4eab1d10604222a3737b3a82a76f358 (diff)
downloadmariadb-git-6c01a22dbdaf478720c444eea74d2c11fa21e9d7.tar.gz
symlink a whole dir, not individual files (symlinking individual files is one subdir below and results in broken links)
cmd-line-utils/readline/Makefile.am: revert BitKeeper/etc/ignore: added include/readline
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 8f71298bbcf..01b8f295be4 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -39,25 +39,23 @@ SUPERCLEANFILES = mysql_version.h my_config.h
DISTCLEANFILES = sched.h $(SUPERCLEANFILES)
clean:
- $(RM) -f readline/*
+ $(RM) -fr readline
distclean:
- $(RM) -f readline/*
+ $(RM) -fr readline
all-local: my_config.h
# Since we include my_config.h it better exist from the beginning
link_sources:
$(CP) ../config.h my_config.h
- $(RM) -fr readline/*
- -mkdir readline
+ -$(RM) -fr readline
@readline_h_ln_cmd@
# Keep automake happy
my_config.h: ../config.h
$(CP) ../config.h my_config.h
- $(RM) -fr readline/*
- -mkdir readline
+ -$(RM) -fr readline
@readline_h_ln_cmd@
# These files should not be included in distributions since they are