summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2006-10-24 22:02:33 +0200
committerunknown <msvensson@neptunus.(none)>2006-10-24 22:02:33 +0200
commit5f79aa753ab94cb0e42088a9c8311af7c9c6d6a7 (patch)
tree489db8e52659114c4f43b718a97776e2b6b88e79 /include/Makefile.am
parent5154dd662594e7ab0e83e77fe5652bfa0eba92da (diff)
parent47b1c7f9a53c4b40cbaaae4da47e78a671bc5836 (diff)
downloadmariadb-git-5f79aa753ab94cb0e42088a9c8311af7c9c6d6a7.tar.gz
Merge neptunus.(none):/home/msvensson/mysql/mysql-5.0-maint
into neptunus.(none):/home/msvensson/mysql/mysql-5.1-new-maint BitKeeper/etc/ignore: auto-union include/Makefile.am: Auto merged include/mysql.h: Auto merged mysql-test/mysql-test-run.pl: Auto merged configure.in: SCCS merged
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am26
1 files changed, 24 insertions, 2 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 26161b36ab8..ae56bbcfa9f 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -15,7 +15,7 @@
# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA
-BUILT_SOURCES = mysql_version.h m_ctype.h my_config.h
+BUILT_SOURCES = mysql_version.h m_ctype.h my_config.h mysql_h.ic
pkginclude_HEADERS = my_dbug.h m_string.h my_sys.h my_list.h my_xml.h \
mysql.h mysql_com.h mysql_embed.h \
my_semaphore.h my_pthread.h my_no_pthread.h \
@@ -36,7 +36,7 @@ noinst_HEADERS = config-win.h config-netware.h \
my_libwrap.h
# mysql_version.h are generated
-CLEANFILES = mysql_version.h my_config.h readline openssl
+CLEANFILES = mysql_version.h my_config.h readline openssl mysql_h.ic
# Some include files that may be moved and patched by configure
DISTCLEANFILES = sched.h $(CLEANFILES)
@@ -54,5 +54,27 @@ my_config.h: ../config.h
dist-hook:
$(RM) -f $(distdir)/mysql_version.h $(distdir)/my_config.h
+#
+# Rules for checking that ABI has not changed
+#
+
+# Create a icheck file for mysql.h
+mysql_h.ic: mysql.h
+ @set -x; \
+ if [ @ICHECK@ != no ] ; then \
+ @ICHECK@ --canonify -o $@ mysql.h; \
+ fi;
+
+# Compare the icheck file to the reference
+check_abi: mysql_h.ic
+ @set -x; \
+ if [ @ICHECK@ != no ] ; then \
+ @ICHECK@ --compare mysql_h.ic mysql_h_abi.ic; \
+ fi; \
+ touch check_abi;
+
+all: check_abi
+
+
# Don't update the files from bitkeeper
%::SCCS/s.%