summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2006-11-04 09:23:19 +0100
committerunknown <msvensson@neptunus.(none)>2006-11-04 09:23:19 +0100
commitf4dd92bd4e3d64f9da973b0a4b47bd5a68e04db2 (patch)
tree248df672449432fd2bde7fb6f9a0e30b20a5ecb3 /include/Makefile.am
parent4c503b8dde4f7f54e487512b07569999ab3e0ca3 (diff)
downloadmariadb-git-f4dd92bd4e3d64f9da973b0a4b47bd5a68e04db2.tar.gz
Updates for abi_check
include/Makefile.am: Remove abi_check from BUILT_SOURCES it's in the "all" rule Make abi_check depend on mysql_h.ic as well
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 6275e04562f..3500503207c 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -15,7 +15,7 @@
# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA
-BUILT_SOURCES = mysql_version.h my_config.h abi_check
+BUILT_SOURCES = mysql_version.h my_config.h
pkginclude_HEADERS = my_dbug.h m_string.h my_sys.h my_list.h my_xml.h \
mysql.h mysql_com.h mysql_embed.h \
my_semaphore.h my_pthread.h my_no_pthread.h raid.h \
@@ -60,7 +60,7 @@ dist-hook:
# Create a icheck file and compare it to the reference
abi_check: mysql.h mysql_version.h mysql_com.h mysql_time.h my_list.h \
- my_alloc.h typelib.h
+ my_alloc.h typelib.h mysql_h.ic
@set -ex; \
if [ @ICHECK@ != no ] ; then \
@ICHECK@ --canonify --skip-from-re /usr/ -o $@.ic mysql.h; \