summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@neptunus.(none)>2006-10-26 22:20:43 +0200
committerunknown <msvensson@neptunus.(none)>2006-10-26 22:20:43 +0200
commitfc72e7623b9b7ce41ab6a63397f7cf8efd91f15b (patch)
tree75cb7d1b4c1384d6af8d8a1d2fdb55aa1ec71d27 /include/Makefile.am
parent08d43705a6ab99779cab4fa281b45e00017f59b8 (diff)
downloadmariadb-git-fc72e7623b9b7ce41ab6a63397f7cf8efd91f15b.tar.gz
Bug#23427 incompatible ABI change in 5.0.26?
- Improve icheck rules in Makefile.am include/Makefile.am: Remove m_ctype from BUILT_SOURCES, it has been in bk for a looong time. Improve the icheck rules - Abort make if icheck fails to compare, very important. - Don't include include files from /usr into the icheck file. Avoids problem when running icheck on different machines. - If no icheck is availabel, touch the mysql_h.ic file so it exists for "make dist" include/mysql_h_abi.ic: Remove all include files from /usr, no need to check that!
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am17
1 files changed, 10 insertions, 7 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index ccb0c322208..40a24b6cb77 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -15,14 +15,14 @@
# Software Foundation, Inc., 59 Temple Place - Suite 330, Boston,
# MA 02111-1307, USA
-BUILT_SOURCES = mysql_version.h m_ctype.h my_config.h mysql_h.ic
+BUILT_SOURCES = mysql_version.h my_config.h mysql_h.ic
pkginclude_HEADERS = my_dbug.h m_string.h my_sys.h my_list.h my_xml.h \
mysql.h mysql_com.h mysql_embed.h \
my_semaphore.h my_pthread.h my_no_pthread.h raid.h \
errmsg.h my_global.h my_net.h my_alloc.h \
my_getopt.h sslopt-longopts.h my_dir.h typelib.h \
sslopt-vars.h sslopt-case.h sql_common.h keycache.h \
- mysql_time.h $(BUILT_SOURCES)
+ mysql_time.h m_ctype.h $(BUILT_SOURCES)
noinst_HEADERS = config-win.h config-os2.h config-netware.h \
heap.h my_bitmap.h\
myisam.h myisampack.h myisammrg.h ft_global.h\
@@ -33,8 +33,8 @@ noinst_HEADERS = config-win.h config-os2.h config-netware.h \
mysql_version.h.in my_handler.h my_time.h decimal.h \
my_user.h my_libwrap.h
-# mysql_version.h are generated
-CLEANFILES = mysql_version.h my_config.h readline openssl mysql_h.ic
+# Remove built files and the symlinked directories
+CLEANFILES = $(BUILT_SOURCES) readline openssl
# Some include files that may be moved and patched by configure
DISTCLEANFILES = sched.h $(CLEANFILES)
@@ -57,15 +57,18 @@ dist-hook:
#
# Create a icheck file for mysql.h
-mysql_h.ic: mysql.h
+mysql_h.ic: mysql.h mysql_version.h mysql_com.h mysql_time.h my_list.h \
+ my_alloc.h typelib.h
@set -x; \
if [ @ICHECK@ != no ] ; then \
- @ICHECK@ --canonify -o $@ mysql.h; \
+ @ICHECK@ --canonify --skip-from-re /usr/ -o $@ mysql.h; \
+ else \
+ touch $@; \
fi;
# Compare the icheck file to the reference
check_abi: mysql_h.ic
- @set -x; \
+ @set -ex; \
if [ @ICHECK@ != no ] ; then \
@ICHECK@ --compare mysql_h.ic mysql_h_abi.ic; \
fi; \