summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-09-24 15:51:45 +0200
committerunknown <kent@mysql.com>2005-09-24 15:51:45 +0200
commit5409f2554f7b1bfc7c736c16b0ebef5668883909 (patch)
treef0bf9c7e18d71c6b6363b180d52a8c4463736bc9 /include/Makefile.am
parentb337566babce87b4a5854f18586206525a4ba1b7 (diff)
downloadmariadb-git-5409f2554f7b1bfc7c736c16b0ebef5668883909.tar.gz
Makefile.am, configure.in:
Enable "make distcheck" to work configure.in: Enable "make distcheck" to work Docs/Makefile.am: Enable "make distcheck" to work Makefile.am: Enable "make distcheck" to work client/Makefile.am: Enable "make distcheck" to work cmd-line-utils/libedit/Makefile.am: Enable "make distcheck" to work include/Makefile.am: Enable "make distcheck" to work libmysql/Makefile.am: Enable "make distcheck" to work libmysql_r/Makefile.am: Enable "make distcheck" to work libmysqld/Makefile.am: Enable "make distcheck" to work libmysqld/examples/Makefile.am: Enable "make distcheck" to work mysql-test/Makefile.am: Enable "make distcheck" to work ndb/docs/Makefile.am: Enable "make distcheck" to work netware/Makefile.am: Enable "make distcheck" to work pstack/Makefile.am: Enable "make distcheck" to work scripts/Makefile.am: Enable "make distcheck" to work sql-bench/Makefile.am: Enable "make distcheck" to work sql/Makefile.am: Enable "make distcheck" to work sql/share/Makefile.am: Enable "make distcheck" to work support-files/Makefile.am: Enable "make distcheck" to work
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am16
1 files changed, 4 insertions, 12 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 0c845900a4f..3fa7b04d69a 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -38,23 +38,15 @@ SUPERCLEANFILES = mysql_version.h my_config.h
# Some include files that may be moved and patched by configure
DISTCLEANFILES = sched.h $(SUPERCLEANFILES)
-clean:
+clean-local:
$(RM) -fr readline
-distclean:
+distclean-local:
$(RM) -fr readline
-all-local: my_config.h
-
-# Since we include my_config.h it better exist from the beginning
-link_sources:
- $(CP) ../config.h my_config.h
- -$(RM) -fr readline
- @readline_h_ln_cmd@
-
-# Keep automake happy
-
my_config.h: ../config.h
$(CP) ../config.h my_config.h
+
+link_sources:
-$(RM) -fr readline
@readline_h_ln_cmd@