summaryrefslogtreecommitdiff
path: root/include/Makefile.am
diff options
context:
space:
mode:
authorunknown <monty@donna.mysql.com>2000-10-17 00:47:15 +0300
committerunknown <monty@donna.mysql.com>2000-10-17 00:47:15 +0300
commit0c511215f23809c4b9e8f5c26ad96520252e7758 (patch)
treeab2709570d10aac2956fa63114d45c79b2b5ea19 /include/Makefile.am
parent9c019f4e4fc4d34f3c82723d1182f0917b9c5360 (diff)
downloadmariadb-git-0c511215f23809c4b9e8f5c26ad96520252e7758.tar.gz
Automatic repair of MyISAM tables + small bug fixes
Docs/manual.texi: Updates for 3.23.26 include/Makefile.am: Install my_config.h include/my_pthread.h: Fix for Ia64 myisam/mi_check.c: Wrong new record pos on dupplicate key error myisam/mi_open.c: Fix for automatic repair myisam/myisamchk.c: Fix for automatic repair myisam/myisamdef.h: Fix for automatic repair mysys/mf_tempfile.c: Fix usage of mkstemp sql-bench/bench-init.pl.sh: Better help text sql-bench/test-insert.sh: Fix for slow databases sql/field.cc: Fix of default values for CREATE TABLE ... SELECT sql/ha_berkeley.cc: Fix bug in BDB records_in_range sql/ha_myisam.cc: Fix for automatic repair sql/ha_myisam.h: Fix for automatic repair sql/handler.cc: Fixes for innobase sql/item_strfunc.cc: Fix for SUBSTR_INDEX and REPLACE sql/log_event.h: Portability fix sql/mysqld.cc: Added INNOBASE and fixes for automatic recover of MyISAM tables sql/sql_base.cc: Fix for automatic repair sql/sql_table.cc: Fix for IF EXISTS when used with CREATE TEMPORARY
Diffstat (limited to 'include/Makefile.am')
-rw-r--r--include/Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/include/Makefile.am b/include/Makefile.am
index 1833ea8096b..f5f290e35da 100644
--- a/include/Makefile.am
+++ b/include/Makefile.am
@@ -30,16 +30,14 @@ noinst_HEADERS = global.h config-win.h \
my_tree.h hash.h thr_alarm.h thr_lock.h \
getopt.h t_ctype.h violite.h \
mysql_version.h.in
-EXTRA_DIST= my_config.h
# mysql_version.h are generated
-SUPERCLEANFILES = mysql_version.h my_global.h
+SUPERCLEANFILES = mysql_version.h my_global.h my_config.h
# Some include files that may be moved and patched by configure
DISTCLEANFILES = sched.h
-CLEANFILES = my_config.h
-all-local: my_global.h
+all-local: my_global.h my_config.h
# Since we include my_config.h it better exist from the beginning
link_sources: