summaryrefslogtreecommitdiff
path: root/libmysql/CMakeLists.txt
diff options
context:
space:
mode:
authorTor Didriksen <tor.didriksen@oracle.com>2012-01-30 10:08:22 +0100
committerTor Didriksen <tor.didriksen@oracle.com>2012-01-30 10:08:22 +0100
commit2a5d2338814a8af37e57fed39196b1b75b455c6c (patch)
tree9ccd1eee88f1bea92d753fa3e2e35c6d9ee6e853 /libmysql/CMakeLists.txt
parent636a7f79e8d208051214a5cb102f8cbdf713a1eb (diff)
downloadmariadb-git-2a5d2338814a8af37e57fed39196b1b75b455c6c.tar.gz
Bug#13604121 - LIBMYSQLCIENT.SO MISSING SOME FUNCTIONS PRESENT IN LIBMYSQLCLIENT.A
+get_tty_password this is the only external symbol in get_password.c, which is explicitly listed in CLIENT_SOURCES +handle_options this is in mysys/my_getopt.c adding this sysmbol pulls in the other externals: T getopt_compare_strings T getopt_double_limit_value T getopt_ll_limit_value T getopt_ull_limit_value T handle_options T my_cleanup_options T my_getopt_register_get_addr T my_print_help T my_print_variables
Diffstat (limited to 'libmysql/CMakeLists.txt')
-rw-r--r--libmysql/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libmysql/CMakeLists.txt b/libmysql/CMakeLists.txt
index 42125cffb7b..9aa338e1563 100644
--- a/libmysql/CMakeLists.txt
+++ b/libmysql/CMakeLists.txt
@@ -25,6 +25,8 @@ INCLUDE_DIRECTORIES(
ADD_DEFINITIONS(${SSL_DEFINES})
SET(CLIENT_API_FUNCTIONS
+get_tty_password
+handle_options
load_defaults
mysql_thread_end
mysql_thread_init