summaryrefslogtreecommitdiff
path: root/libmysql/Makefile.am
diff options
context:
space:
mode:
authorhf@deer.(none) <>2003-05-31 15:15:46 +0500
committerhf@deer.(none) <>2003-05-31 15:15:46 +0500
commit02d3d7e8bd0b5a582befe8d02d41c9cca1bcfe8e (patch)
tree4dd324e7d5c4509bfa76cfb1ebecf8f75b9cc6f5 /libmysql/Makefile.am
parent6bc3473f8883783f4613d25af99f89f06b12c600 (diff)
downloadmariadb-git-02d3d7e8bd0b5a582befe8d02d41c9cca1bcfe8e.tar.gz
SCRUM:
Here is another pack of changes about gathering common client code in sql-common/client.c. Now i symlink the client.c from sql/ and libmysql/. These directories have client_settings.h files to be included to client.c. It contains defines and declarations to compile client.c in appropriate manner. Also i've added include/sql_common.h, containing declarations of what is exported from client.c I removed as many #ifdef-s from client.c as i dared to. I think it's better push it with some extra #ifdef-s now (of course, if everythihg besides it is ok) so other people can check the code.
Diffstat (limited to 'libmysql/Makefile.am')
-rw-r--r--libmysql/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/libmysql/Makefile.am b/libmysql/Makefile.am
index 2e0a18d4677..128f1c03967 100644
--- a/libmysql/Makefile.am
+++ b/libmysql/Makefile.am
@@ -18,7 +18,7 @@
# This file is public domain and comes with NO WARRANTY of any kind
target = libmysqlclient.la
-target_defs = -DUNDEF_THREADS_HACK -DDONT_USE_RAID @LIB_EXTRA_CCFLAGS@ -DMYSQL_CLIENT
+target_defs = -DUNDEF_THREADS_HACK -DDONT_USE_RAID @LIB_EXTRA_CCFLAGS@
LIBS = @CLIENT_LIBS@
INCLUDES = -I$(top_srcdir)/include $(openssl_includes)
@@ -79,7 +79,8 @@ nh = my_global.h config-win32.h dbug.h errmsg.h \
m_ctype.h m_string.h \
my_alarm.h my_config.h my_dir.h my_list.h my_net.h my_sys.h \
mysql.h mysql_com.h mysql_version.h mysqld_error.h \
- mysys_err.h my_pthread.h thr_alarm.h violite.h hash.h
+ mysys_err.h my_pthread.h thr_alarm.h violite.h hash.h \
+ sql_common.h ../libmysql/client_settings.h
# Get a list of the needed objects
lobjs = $(mysysobjects1) $(dbugobjects) $(mystringsobjects) $(sqlobjects)