summaryrefslogtreecommitdiff
path: root/libmysql/Makefile.am
diff options
context:
space:
mode:
authorunknown <knielsen@mysql.com>2006-03-24 22:50:56 +0100
committerunknown <knielsen@mysql.com>2006-03-24 22:50:56 +0100
commit230eab3c68cb26fa743e82d0452f0b83359a10ff (patch)
tree4a3cb807ddfab7cd04cb6caf42623f824843f884 /libmysql/Makefile.am
parenta69a37835c1b3823b359b7a4e1ae7bdafd33a08a (diff)
downloadmariadb-git-230eab3c68cb26fa743e82d0452f0b83359a10ff.tar.gz
Some changes to make it possible to build for Windows with CMake from
a normal 'make dist' source .tar.gz. libmysql/mytest.c: bk cp VC++Files/libmysqltest/mytest.c libmysql/mytest.c sql/message.mc: bk cp VC++Files/sql/message.mc sql/message.mc Makefile.am: Add Windows CMake stuff. client/Makefile.am: Add extra files needed for CMake Windows build. cmakelists.txt: Fix subdir order to make CMake dependency calculations happy. configure.in: Add extra files needed for CMake Windows build. extra/Makefile.am: Add extra files needed for CMake Windows build. extra/yassl/Makefile.am: Add extra files needed for CMake Windows build. libmysql/Makefile.am: Add extra files needed for CMake Windows build. libmysql/cmakelists.txt: Move mytest.c to a more sensible location. libmysqld/Makefile.am: Add extra files needed for CMake Windows build. mysys/Makefile.am: Add extra files needed for CMake Windows build. regex/Makefile.am: Add extra files needed for CMake Windows build. server-tools/instance-manager/Makefile.am: Add extra files needed for CMake Windows build. sql/Makefile.am: Add extra files needed for CMake Windows build. sql/cmakelists.txt: Move message.mc to a more sensible location. Add some dependencies to avoid a stale handlerton.cc. storage/archive/Makefile.am: Add extra files needed for CMake Windows build. storage/bdb/Makefile.in: Add extra files needed for CMake Windows build. storage/example/Makefile.am: Add extra files needed for CMake Windows build. storage/heap/Makefile.am: Add extra files needed for CMake Windows build. storage/innobase/Makefile.am: Add extra files needed for CMake Windows build. storage/innobase/include/univ.i: Avoid including Unix config in Windows build. storage/myisam/Makefile.am: Add extra files needed for CMake Windows build. storage/myisammrg/Makefile.am: Add extra files needed for CMake Windows build. strings/Makefile.am: Add extra files needed for CMake Windows build. tests/Makefile.am: Add extra files needed for CMake Windows build. vio/Makefile.am: Add extra files needed for CMake Windows build. zlib/Makefile.am: Add extra files needed for CMake Windows build.
Diffstat (limited to 'libmysql/Makefile.am')
-rw-r--r--libmysql/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libmysql/Makefile.am b/libmysql/Makefile.am
index a3e16b521a9..8cc29ec690a 100644
--- a/libmysql/Makefile.am
+++ b/libmysql/Makefile.am
@@ -31,7 +31,7 @@ include $(srcdir)/Makefile.shared
libmysqlclient_la_SOURCES = $(target_sources)
libmysqlclient_la_LIBADD = $(target_libadd) $(yassl_libs_with_path)
libmysqlclient_la_LDFLAGS = $(target_ldflags)
-EXTRA_DIST = Makefile.shared libmysql.def
+EXTRA_DIST = Makefile.shared libmysql.def dll.c mytest.c cmakelists.txt
noinst_HEADERS = client_settings.h
# This is called from the toplevel makefile