summaryrefslogtreecommitdiff
path: root/libmysql/Makefile.am
diff options
context:
space:
mode:
authormonty@mashka.mysql.fi <>2002-10-02 13:33:08 +0300
committermonty@mashka.mysql.fi <>2002-10-02 13:33:08 +0300
commitd69250a969449da43891ef5b2859df77917183a8 (patch)
tree5a27bda6d3f628af7dcb922ad022e84cf8cb351c /libmysql/Makefile.am
parent7134ffec210edde21860a2b2c2654be481de49b4 (diff)
downloadmariadb-git-d69250a969449da43891ef5b2859df77917183a8.tar.gz
Fixes and code cleanups after merge with 4.0.3
Warning handling and initial prepared statement handling (last not complete yet) Changed a lot of functions that returned 0/1 to my_bool type. GRANT handling now uses read/write locks instead of mutex Change basic net functions to use THD instead of NET (needed for 4.1 protocol) Use my_sprintf instead of sprintf() + strlen() Added alloc_query() to be able to chare query initialization code with prepared statements. Cleanup handling of SHOW COUNT(*) WARNINGS and SELECT LAST_INSERT_ID() Note that the following test fails (will be fixed ASAP): sub_select, union, rpl_rotate_logs and rpl_mystery22
Diffstat (limited to 'libmysql/Makefile.am')
-rw-r--r--libmysql/Makefile.am4
1 files changed, 0 insertions, 4 deletions
diff --git a/libmysql/Makefile.am b/libmysql/Makefile.am
index fac544ba44d..3d380c14076 100644
--- a/libmysql/Makefile.am
+++ b/libmysql/Makefile.am
@@ -49,10 +49,6 @@ link_sources:
rm -f $(srcdir)/$$f; \
@LN_CP_F@ $(srcdir)/../strings/$$f $(srcdir)/$$f; \
done; \
- for f in $(mystringsgen); do \
- rm -f $(srcdir)/$$f; \
- @LN_CP_F@ ../strings/$$f $(srcdir)/$$f; \
- done; \
for f in $$qs; do \
rm -f $(srcdir)/$$f; \
@LN_CP_F@ $(srcdir)/../sql/$$f $(srcdir)/$$f; \