summaryrefslogtreecommitdiff
path: root/libmysql/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2006-04-01 01:24:28 +0200
committerunknown <kent@mysql.com>2006-04-01 01:24:28 +0200
commit872d1d71a1d6b6aba2aa0af98cdffb4bb3c01325 (patch)
tree00ced9c27de60a02e0481185d3be265303992e56 /libmysql/Makefile.am
parentfa7e5ed5d7c6f40ddebe88de099f4ba0ee502d47 (diff)
downloadmariadb-git-872d1d71a1d6b6aba2aa0af98cdffb4bb3c01325.tar.gz
Makefile.am, yassl.m4:
Enable automake to determine dependency on yaSSL, by explicitly listing the .la files in Makefile.am, instead of using 'yassl_libs_with_path', bug#18273 config/ac-macros/yassl.m4: Enable automake to determine dependency on yaSSL, by explicitly listing the .la files in Makefile.am, instead of using 'yassl_libs_with_path', bug#18273 libmysql/Makefile.am: Enable automake to determine dependency on yaSSL, by explicitly listing the .la files in Makefile.am, instead of using 'yassl_libs_with_path', bug#18273 libmysql_r/Makefile.am: Enable automake to determine dependency on yaSSL, by explicitly listing the .la files in Makefile.am, instead of using 'yassl_libs_with_path', bug#18273
Diffstat (limited to 'libmysql/Makefile.am')
-rw-r--r--libmysql/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/libmysql/Makefile.am b/libmysql/Makefile.am
index a3e16b521a9..2c7dc572b5e 100644
--- a/libmysql/Makefile.am
+++ b/libmysql/Makefile.am
@@ -29,7 +29,11 @@ INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
include $(srcdir)/Makefile.shared
libmysqlclient_la_SOURCES = $(target_sources)
-libmysqlclient_la_LIBADD = $(target_libadd) $(yassl_libs_with_path)
+libmysqlclient_la_LIBADD = $(target_libadd)
+if HAVE_YASSL
+libmysqlclient_la_LIBADD+= $(top_srcdir)/extra/yassl/src/libyassl.la \
+ $(top_srcdir)/extra/yassl/taocrypt/src/libtaocrypt.la
+endif
libmysqlclient_la_LDFLAGS = $(target_ldflags)
EXTRA_DIST = Makefile.shared libmysql.def
noinst_HEADERS = client_settings.h