summaryrefslogtreecommitdiff
path: root/libmysql/Makefile.am
diff options
context:
space:
mode:
authormsvensson@shellback.(none) <>2006-05-31 16:19:06 +0200
committermsvensson@shellback.(none) <>2006-05-31 16:19:06 +0200
commit20217ba36f11fde8eba391bab6fdeaed28900d73 (patch)
treeeec37d5fd4ee259d7eacec279bb80e6952f0a995 /libmysql/Makefile.am
parent971dc90e3ae52ec34f09f3d706c51ee2dab53177 (diff)
downloadmariadb-git-20217ba36f11fde8eba391bab6fdeaed28900d73.tar.gz
Bug#19575 MySQL-shared-5.0.21-0.glibc23 causes segfault in SSL_library_init
- Include prefix files that renames all public functions in yaSSLs OpenSSL API to ya<function_name>. They will otherwise conflict with OpenSSL functions if loaded by an application that uses OpenSSL as well as libmysqlclient with yaSSL support.
Diffstat (limited to 'libmysql/Makefile.am')
-rw-r--r--libmysql/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libmysql/Makefile.am b/libmysql/Makefile.am
index b580884e934..d089d56f38a 100644
--- a/libmysql/Makefile.am
+++ b/libmysql/Makefile.am
@@ -24,7 +24,7 @@ target = libmysqlclient.la
target_defs = -DUNDEF_THREADS_HACK -DDONT_USE_RAID @LIB_EXTRA_CCFLAGS@
LIBS = @CLIENT_LIBS@
INCLUDES = -I$(top_builddir)/include -I$(top_srcdir)/include \
- $(openssl_includes) $(yassl_includes) @ZLIB_INCLUDES@
+ $(openssl_includes) @ZLIB_INCLUDES@
include $(srcdir)/Makefile.shared