summaryrefslogtreecommitdiff
path: root/libmysqld/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-03-17 19:56:22 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-03-17 19:56:22 +0100
commit78a965861a3300c321775c65f54dd541bc5d3d49 (patch)
tree2d7936920bf092e313f7acff9b9c014bc576da0e /libmysqld/CMakeLists.txt
parent148c2c316df0dd2b6d29212d59d2339dedeaa272 (diff)
downloadmariadb-git-78a965861a3300c321775c65f54dd541bc5d3d49.tar.gz
Bug #52149 - packaging differences in CMake build
Corrected some packaging bugs: - install mysqlservices library - install libmysqlclient_r.so.{16,16.0.0} as links to libmysqlclient.so - install libmysqld-debug.a - install my_safe_process, my_safe_kill and symlinks to mysql-test-run.pl (mtr, mysql-test-run) into correct place ${INSTALL_MYSQLTESTDIR}
Diffstat (limited to 'libmysqld/CMakeLists.txt')
-rw-r--r--libmysqld/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/libmysqld/CMakeLists.txt b/libmysqld/CMakeLists.txt
index e5f2a8b56f9..26332cab61b 100644
--- a/libmysqld/CMakeLists.txt
+++ b/libmysqld/CMakeLists.txt
@@ -131,6 +131,11 @@ IF(MSVC)
INSTALL_DEBUG_TARGET(mysqlserver DESTINATION ${INSTALL_LIBDIR}/debug)
ENDIF()
+IF(UNIX)
+ INSTALL_DEBUG_TARGET(mysqlserver DESTINATION ${INSTALL_LIBDIR} RENAME
+ ${CMAKE_STATIC_LIBRARY_PREFIX}/mysqld-debug)
+ENDIF()
+
IF(MSVC AND NOT DISABLE_SHARED)
MERGE_LIBRARIES(libmysqld SHARED ${LIBS} EXPORTS ${CLIENT_API_FUNCTIONS})
ENDIF()