summaryrefslogtreecommitdiff
path: root/libmysqld/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@koala>2009-12-07 02:16:05 +0100
committerVladislav Vaintroub <vvaintroub@koala>2009-12-07 02:16:05 +0100
commit9fcef3c45bd936b7da20679a1bb160c22f4945ff (patch)
treebe34c035a12551aff48f3bcdb4fcbf4754f8b3f0 /libmysqld/CMakeLists.txt
parent2e6270311467f557a424a15b03d8d52c5b0ea92d (diff)
downloadmariadb-git-9fcef3c45bd936b7da20679a1bb160c22f4945ff.tar.gz
On Linux, support -Wl,--no-undefined (only client shared library)
and --Wl,--as-needed (all shared modules). The later will remove unused dependencies (also from gcc and C++ runtime)
Diffstat (limited to 'libmysqld/CMakeLists.txt')
-rw-r--r--libmysqld/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/libmysqld/CMakeLists.txt b/libmysqld/CMakeLists.txt
index 7378d23790d..56e16e6cd1c 100644
--- a/libmysqld/CMakeLists.txt
+++ b/libmysqld/CMakeLists.txt
@@ -100,7 +100,8 @@ ENDIF()
SET(LIBS
dbug strings regex mysys vio
- ${ZLIB_LIBRARY} ${SSL_LIBRARIES} ${LIBWRAP_LIBRARY}
+ ${ZLIB_LIBRARY} ${SSL_LIBRARIES}
+ ${LIBWRAP} ${LIBCRYPT} ${LIBDL}
${MYSQLD_STATIC_PLUGIN_LIBS} ${NDB_CLIENT_LIBS}
sql_embedded
)