summaryrefslogtreecommitdiff
path: root/libmysqld/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael Widenius <monty@askmonty.org>2011-02-23 11:22:56 +0200
committerMichael Widenius <monty@askmonty.org>2011-02-23 11:22:56 +0200
commit1c23091c4ecc23100a6fe42288819cf4d5dc0b5b (patch)
treedb09f3c0fa94cc3151b0b50e57008e361608aa98 /libmysqld/CMakeLists.txt
parente079f3c84a24e67f2da3ae0b0c338d5b79dc9516 (diff)
downloadmariadb-git-1c23091c4ecc23100a6fe42288819cf4d5dc0b5b.tar.gz
Fixed build failures
- Removed references to deleted files - If we link staticly, check for static zlib - This should fix the problem with 'no -lz found' link error - Fixed build failure on window (Patch from Wlad) - Fixed build problem with federatedx when using -Werror BUILD/Makefile.am: Remove removed file config/ac-macros/zlib.m4: If we compile with --all-static, test that we have a static libz libmysqld/CMakeLists.txt: Fix for build error on windows mysql-test/suite/pbxt/r/key_cache.result: Updated result mysql-test/suite/pbxt/t/key_cache.test: Fixed not updated test case sql/CMakeLists.txt: Fix for build error on windows storage/federatedx/Makefile.am: Don't use CFLAGS to compile C++ programs storage/pbxt/src/lock_xt.cc: Fixed compiler warning about using uninitialized b2 storage/xtradb/buf/buf0buf.c: Fixed wrong printf storage/xtradb/srv/srv0srv.c: Fixed assignment of different width and test with different sign/unsigned
Diffstat (limited to 'libmysqld/CMakeLists.txt')
-rw-r--r--libmysqld/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/libmysqld/CMakeLists.txt b/libmysqld/CMakeLists.txt
index e50e89082cd..f9ef76f29ec 100644
--- a/libmysqld/CMakeLists.txt
+++ b/libmysqld/CMakeLists.txt
@@ -153,6 +153,12 @@ ADD_LIBRARY(mysqlserver STATIC ${LIBMYSQLD_SOURCES})
ADD_DEPENDENCIES(mysqlserver GenServerSource GenError)
TARGET_LINK_LIBRARIES(mysqlserver psapi.lib)
+IF(MSVC AND CMAKE_SIZEOF_VOID_P MATCHES 8)
+ # Workaround cmake bug http://www.vtk.org/Bug/view.php?id=11240
+ SET_TARGET_PROPERTIES(mysqlserver PROPERTIES STATIC_LIBRARY_FLAGS
+ "/MACHINE:AMD64")
+ENDIF()
+
# Add any additional libraries requested by engine(s)
FOREACH (ENGINE_LIB ${MYSQLD_STATIC_ENGINE_LIBS})
STRING(TOUPPER ${ENGINE_LIB} ENGINE_LIB_UPPER)