summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authorunknown <jperkin/jonathan@chorlton.adsl.perkin.org.uk>2007-12-19 13:24:43 +0000
committerunknown <jperkin/jonathan@chorlton.adsl.perkin.org.uk>2007-12-19 13:24:43 +0000
commit92e31e96a2c6f2f98e77217534fcc3712e7b4fa5 (patch)
tree7e366b1d392d7928acf0727223f607ab5edd44d4 /libmysqld/Makefile.am
parent333af686bf68b4c0e6d424ce07dda2196df4a2c3 (diff)
downloadmariadb-git-92e31e96a2c6f2f98e77217534fcc3712e7b4fa5.tar.gz
Add new pkgplugindir handling to seperate plugins from libraries,
and allow override for binary distributions. Extend mysql_config to print compiled-in plugin location for third-party plugins to use. Resolves bug#31736. libmysqld/Makefile.am: Use pkgplugindir. plugin/daemon_example/Makefile.am: Use pkgplugindir. plugin/fulltext/Makefile.am: Use pkgplugindir. scripts/Makefile.am: Add pkgplugindir. scripts/make_binary_distribution.sh: Add pkgplugindir. scripts/mysql_config.sh: Add pkgplugindir. sql/Makefile.am: Use pkgplugindir. sql/mysqld.cc: Use PLUGINDIR, derived from pkgplugindir, instead of LIBDIR for plugins. sql/unireg.h: Use PLUGINDIR instead of LIBDIR, and define to be the default setting of pkgplugindir. storage/innobase/Makefile.am: Use pkgplugindir. storage/archive/Makefile.am: Use pkgplugindir. storage/blackhole/Makefile.am: Use pkgplugindir. storage/example/Makefile.am: Use pkgplugindir. storage/federated/Makefile.am: Use pkgplugindir.
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index c0784447216..117f8752629 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -21,13 +21,14 @@ MYSQLDATAdir = $(localstatedir)
MYSQLSHAREdir = $(pkgdatadir)
MYSQLBASEdir= $(prefix)
MYSQLLIBdir= $(libdir)
+pkgplugindir = $(libdir)/@PACKAGE@/plugin
EXTRA_DIST = libmysqld.def CMakeLists.txt
DEFS = -DEMBEDDED_LIBRARY -DMYSQL_SERVER \
-DDEFAULT_MYSQL_HOME="\"$(MYSQLBASEdir)\"" \
-DDATADIR="\"$(MYSQLDATAdir)\"" \
-DSHAREDIR="\"$(MYSQLSHAREdir)\"" \
- -DLIBDIR="\"$(MYSQLLIBdir)\""
+ -DPLUGINDIR="\"$(pkgplugindir)\""
INCLUDES= -I$(top_builddir)/include -I$(top_srcdir)/include \
-I$(top_builddir)/sql -I$(top_srcdir)/sql \
-I$(top_srcdir)/sql/examples \