summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@kent-amd64.(none)>2006-11-27 23:12:05 +0100
committerunknown <kent@kent-amd64.(none)>2006-11-27 23:12:05 +0100
commit90feb661d5af4de00eb4165e575c145f722b92c5 (patch)
treebb94dba41000bf4e2bcc5bd5ebbfe118fb9db103 /libmysqld/Makefile.am
parentd2f7b75b9e978c814cf0caf02fbd866db385ed49 (diff)
parente9c502b3995c2e8dd0b5c3fb878e371a548989ba (diff)
downloadmariadb-git-90feb661d5af4de00eb4165e575c145f722b92c5.tar.gz
Merge mysql.com:/home/kent/bk/mysql-5.0
into mysql.com:/home/kent/bk/mysql-5.1 BitKeeper/deleted/.del-gen_rec.awk: Auto merged client/mysql_upgrade.c: Auto merged configure.in: Auto merged extra/yassl/src/Makefile.am: Auto merged extra/yassl/taocrypt/benchmark/Makefile.am: Auto merged extra/yassl/taocrypt/benchmark/benchmark.dsp: Auto merged extra/yassl/taocrypt/src/Makefile.am: Auto merged extra/yassl/taocrypt/taocrypt.dsp: Auto merged extra/yassl/taocrypt/taocrypt.vcproj: Auto merged extra/yassl/taocrypt/test.dsp: Auto merged extra/yassl/taocrypt/test/Makefile.am: Auto merged extra/yassl/testsuite/Makefile.am: Auto merged extra/yassl/testsuite/testsuite.dsp: Auto merged extra/yassl/yassl.dsp: Auto merged extra/yassl/yassl.vcproj: Auto merged include/my_sys.h: Auto merged libmysql/Makefile.shared: Auto merged mysql-test/mysql-test-run.pl: Auto merged BitKeeper/deleted/.del-ha_berkeley.m4: Auto merged mysql-test/lib/mtr_report.pl: Auto merged sql-common/my_time.c: Auto merged storage/ndb/config/common.mk.am: Auto merged storage/ndb/config/type_kernel.mk.am: Auto merged storage/ndb/config/type_ndbapi.mk.am: Auto merged storage/ndb/config/type_ndbapitest.mk.am: Auto merged storage/ndb/config/type_ndbapitools.mk.am: Auto merged storage/ndb/config/type_util.mk.am: Auto merged Docs/Makefile.am: SCCS merged
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am22
1 files changed, 17 insertions, 5 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index 0de37db63e2..7eb160776e0 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -29,8 +29,8 @@ DEFS = -DEMBEDDED_LIBRARY -DMYSQL_SERVER \
-DSHAREDIR="\"$(MYSQLSHAREdir)\"" \
-DLIBDIR="\"$(MYSQLLIBdir)\""
INCLUDES= -I$(top_builddir)/include -I$(top_srcdir)/include \
- -I$(top_builddir)/include -I$(top_srcdir)/include \
- -I$(top_srcdir)/sql -I$(top_srcdir)/sql/examples \
+ -I$(top_builddir)/sql -I$(top_srcdir)/sql \
+ -I$(top_srcdir)/sql/examples \
-I$(top_srcdir)/regex \
$(openssl_includes) @ZLIB_INCLUDES@ \
@condition_dependent_plugin_includes@
@@ -155,16 +155,28 @@ endif
#libmysqld_la_LDFLAGS = -version-info @SHARED_LIB_VERSION@
#CLEANFILES = $(libmysqld_la_LIBADD) libmysqld.la
-# This is called from the toplevel makefile
+# This is called from the toplevel makefile. If we can link now
+# to an existing file in source, we do that, else we assume it
+# will show up in the build tree eventually (generated file).
link_sources:
set -x; \
for f in $(sqlsources); do \
rm -f $$f; \
- @LN_CP_F@ $(top_srcdir)/sql/$$f $$f; \
+ if test -e $(top_srcdir)/sql/$$f ; \
+ then \
+ @LN_CP_F@ $(top_srcdir)/sql/$$f $$f; \
+ else \
+ @LN_CP_F@ $(top_builddir)/sql/$$f $$f; \
+ fi ; \
done; \
for f in $(libmysqlsources); do \
rm -f $$f; \
- @LN_CP_F@ $(top_srcdir)/libmysql/$$f $$f; \
+ if test -e $(top_srcdir)/libmysql/$$f ; \
+ then \
+ @LN_CP_F@ $(top_srcdir)/libmysql/$$f $$f; \
+ else \
+ @LN_CP_F@ $(top_builddir)/libmysql/$$f $$f; \
+ fi ; \
done; \
if test -n "$(sqlstoragesources)" ; \
then \