summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authorunknown <tim@white.box>2001-08-21 19:04:31 -0400
committerunknown <tim@white.box>2001-08-21 19:04:31 -0400
commit003d978acd505b3db36418f326782dc4ac55b9a7 (patch)
treeca5489dfe0fe3741cd56b3cf37c518d108839342 /libmysqld/Makefile.am
parente3a9e7e40e63e8bed554cfbceacf29490df1a14a (diff)
downloadmariadb-git-003d978acd505b3db36418f326782dc4ac55b9a7.tar.gz
Fix some libmysqld problems.
BitKeeper/etc/ignore: Added libmysqld/ha_innobase.cc to the ignore list libmysqld/Makefile.am: Add ha_innobase.cc to libmysqld. libmysqld/lib_sql.cc: Hack to get shutdown working properly in libmysqld. Probably this is not quite correct. sql/mini_client.cc: Remove name collision in embedded libmysqld.
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index 02d2d007b5d..aaa2b469ccb 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -40,7 +40,7 @@ libmysqlsources = errmsg.c get_password.c password.c
libmysqlobjects = errmsg.lo get_password.lo password.lo
sqlsources = convert.cc derror.cc field.cc field_conv.cc filesort.cc \
- ha_berkeley.cc ha_heap.cc ha_isam.cc ha_isammrg.cc \
+ ha_innobase.cc ha_berkeley.cc ha_heap.cc ha_isam.cc ha_isammrg.cc \
ha_myisam.cc ha_myisammrg.cc handler.cc sql_handler.cc \
hostname.cc init.cc \
item.cc item_buff.cc item_cmpfunc.cc item_create.cc \
@@ -58,7 +58,7 @@ sqlsources = convert.cc derror.cc field.cc field_conv.cc filesort.cc \
## XXX: we should not have to duplicate info from the sources list
sqlobjects = convert.lo derror.lo field.lo field_conv.lo filesort.lo \
- ha_berkeley.lo ha_heap.lo ha_isam.lo ha_isammrg.lo \
+ ha_innobase.lo ha_berkeley.lo ha_heap.lo ha_isam.lo ha_isammrg.lo \
ha_myisam.lo ha_myisammrg.lo handler.lo sql_handler.lo \
hostname.lo init.lo \
item.lo item_buff.lo item_cmpfunc.lo item_create.lo \