summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authorunknown <holyfoot/hf@mysql.com/hfmain.(none)>2006-12-28 09:42:04 +0400
committerunknown <holyfoot/hf@mysql.com/hfmain.(none)>2006-12-28 09:42:04 +0400
commit333b2684af77673c9019748865c2967226de678e (patch)
tree98d5ea35a1c1b4733dc237d98ddba348ece8c639 /libmysqld/Makefile.am
parent1aa1efdbd3cae8c9bc0524c92dda4c8084ec5b7c (diff)
downloadmariadb-git-333b2684af77673c9019748865c2967226de678e.tar.gz
WL#3630 (add embedded server to pushbuild)
5.1-related fixes libmysqld/Makefile.am fixed to recompile and link ha_*.cc files that keep dependance on THD structure. Minor fixes to make tests working. config/ac-macros/plugins.m4: condition_dependent_plugin_objects added libmysqld/Makefile.am: rules for ha_*.o files added condition_dependent_plugin_objects sent to linker libmysqld/lib_sql.cc: ddl_log initialization added mysql-test/r/flush_block_commit_notembedded.result: result fixed mysql-test/t/crash_commit_before.test: doesn't work in embedded server mysql-test/t/csv.test: replace_result added mysql-test/t/ps.test: doesn't work in embedded server should be fixed by separating ps_notembedded.test mysql-test/t/ps_1general.test: replace_result fixed mysql-test/t/ps_not_windows.test: doesn't work in embedded server mysql-test/t/trigger.test: replace_result fixed sql/sql_insert.cc: #ifdef HAVE_ROW_BASED_REPLICATION added storage/myisam/ha_myisam.cc: MY_UNPACK_FILENAME flag added
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am28
1 files changed, 24 insertions, 4 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index cf4f90d99c9..2008b0e66a2 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -79,6 +79,7 @@ libmysqld_a_SOURCES=
sqlstoragesources = $(EXTRA_libmysqld_a_SOURCES)
storagesources = @condition_dependent_plugin_modules@
+storageobjects = @condition_dependent_plugin_objects@
storagesourceslinks = @condition_dependent_plugin_links@
# automake misses these
@@ -109,6 +110,24 @@ ha_ndbcluster_binlog.o: ha_ndbcluster_binlog.cc
handler.o: handler.cc
$(CXXCOMPILE) @ndbcluster_includes@ $(LM_CFLAGS) -c $<
+# We need rules to compile these as no good way
+# found to append fileslists that collected by configure
+# to the sources list
+
+ha_federated.o:ha_federated.cc
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
+ha_heap.o:ha_heap.cc
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
+ha_innodb.o:ha_innodb.cc
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
+ha_myisam.o:ha_myisam.cc
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
+
+ha_myisammrg.o:ha_myisammrg.cc
+ $(CXXCOMPILE) $(LM_CFLAGS) -c $<
#
# To make it easy for the end user to use the embedded library we
@@ -120,18 +139,18 @@ handler.o: handler.cc
# need to add the same file twice to the library, so 'sort -u' save us
# some time and spares unnecessary work.
-libmysqld.a: libmysqld_int.a $(INC_LIB) $(libmysqld_a_DEPENDENCIES)
+libmysqld.a: libmysqld_int.a $(INC_LIB) $(libmysqld_a_DEPENDENCIES) $(storageobjects)
if DARWIN_MWCC
- mwld -lib -o $@ libmysqld_int.a `echo $(INC_LIB) | sort -u`
+ mwld -lib -o $@ libmysqld_int.a `echo $(INC_LIB) | sort -u` $(storageobjects)
else
-rm -f libmysqld.a
if test "$(host_os)" = "netware" ; \
then \
- $(libmysqld_a_AR) libmysqld.a libmysqld_int.a $(INC_LIB) ; \
+ $(libmysqld_a_AR) libmysqld.a $(INC_LIB) libmysqld_int.a $(storageobjects); \
else \
current_dir=`pwd`; \
rm -rf tmp; mkdir tmp; \
- (for arc in ./libmysqld_int.a $(INC_LIB); do \
+ (for arc in $(INC_LIB) ./libmysqld_int.a; do \
arpath=`echo $$arc|sed 's|[^/]*$$||'|sed 's|\.libs/$$||'`; \
artmp=`echo $$arc|sed 's|^.*/|tmp/lib-|'`; \
for F in `$(AR) t $$arc | grep -v SYMDEF`; do \
@@ -142,6 +161,7 @@ else
ls $$artmp/* | grep -v SYMDEF; \
continue 2; fi; done; \
done; echo $(libmysqld_a_DEPENDENCIES) ) | sort -u | xargs $(AR) cq libmysqld.a ; \
+ $(AR) r libmysqld.a $(storageobjects); \
$(RANLIB) libmysqld.a ; \
rm -rf tmp; \
fi