summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com/c-544072d5.010-2112-6f72651.cust.bredbandsbolaget.se>2006-10-19 04:38:16 +0200
committerunknown <kent@mysql.com/c-544072d5.010-2112-6f72651.cust.bredbandsbolaget.se>2006-10-19 04:38:16 +0200
commitc475d9e3d3a96571ed4bd40d7c785fc858e912ed (patch)
tree5dfda81e83fb4cb065aa417b566f349cb8ff1e51 /libmysqld/Makefile.am
parent3720111cec4d60838b44873c76aebcd490a5da87 (diff)
downloadmariadb-git-c475d9e3d3a96571ed4bd40d7c785fc858e912ed.tar.gz
Makefile.am:
Quote variable in "for"-loop head, in case it can be empty. libmysqld/Makefile.am: Quote variable in "for"-loop head, in case it can be empty.
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index 0de37db63e2..81da3daabc1 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -158,11 +158,11 @@ endif
# This is called from the toplevel makefile
link_sources:
set -x; \
- for f in $(sqlsources); do \
+ for f in "$(sqlsources)"; do \
rm -f $$f; \
@LN_CP_F@ $(top_srcdir)/sql/$$f $$f; \
done; \
- for f in $(libmysqlsources); do \
+ for f in "$(libmysqlsources)"; do \
rm -f $$f; \
@LN_CP_F@ $(top_srcdir)/libmysql/$$f $$f; \
done; \
@@ -176,7 +176,7 @@ link_sources:
if test -n "$(storagesources)" ; \
then \
rm -f $(storagesources); \
- for f in $(storagesourceslinks); do \
+ for f in "$(storagesourceslinks)"; do \
@LN_CP_F@ $(top_srcdir)/$$f . ; \
done; \
fi; \