summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authorunknown <malff/marcsql@weblab.(none)>2007-01-11 14:58:05 -0700
committerunknown <malff/marcsql@weblab.(none)>2007-01-11 14:58:05 -0700
commitcdb60578f4ca6797bcc36ad0ec935aa1593ca405 (patch)
tree53f7cc34c8a22ed9ceaf16d39f046e08a1c24778 /libmysqld/Makefile.am
parent552d4cede57926ecfba91624e9ef2a72cf1bd81f (diff)
downloadmariadb-git-cdb60578f4ca6797bcc36ad0ec935aa1593ca405.tar.gz
Bug#22687 (Functions UNIQUE_USERS, GROUP_UNIQUE_USERS)
According to some internal communication, these two functions are place holders for future enhancements. Because they use a variable number of parameters, the implementation defined a reserved keyword for them in the parser grammar. Unfortunately, doing so creates a bug similar to Bug 21114 reported for the function FORMAT. In the 5.1 code base, due to improvements in the code implemented with bug 21114, having a reserved keyword for functions with a variable number of arguments is not needed any more by the implementation. As a result, this fix removes the place-holder implementation, and removes the unnecessary reserved keywords. Should the functions UNIQUE_USERS and GROUP_UNIQUE_USERS be finally implemented in a later release, the implementation should sub class Create_native_func in sql/item_create.cc. For example, see the class Create_func_concat. BitKeeper/deleted/.del-item_uniq.cc: Rename: sql/item_uniq.cc -> BitKeeper/deleted/.del-item_uniq.cc BitKeeper/deleted/.del-item_uniq.h: Rename: sql/item_uniq.h -> BitKeeper/deleted/.del-item_uniq.h libmysqld/Makefile.am: Remove native functions UNIQUE_USERS() and GROUP_UNIQUE_USERS(). mysql-test/r/parser.result: Remove native functions UNIQUE_USERS() and GROUP_UNIQUE_USERS(). mysql-test/t/parser.test: Remove native functions UNIQUE_USERS() and GROUP_UNIQUE_USERS(). sql/Makefile.am: Remove native functions UNIQUE_USERS() and GROUP_UNIQUE_USERS(). sql/item.h: Remove native functions UNIQUE_USERS() and GROUP_UNIQUE_USERS(). sql/item_sum.h: Remove native functions UNIQUE_USERS() and GROUP_UNIQUE_USERS(). sql/lex.h: Remove native functions UNIQUE_USERS() and GROUP_UNIQUE_USERS(). sql/mysql_priv.h: Remove native functions UNIQUE_USERS() and GROUP_UNIQUE_USERS(). sql/sql_yacc.yy: Remove native functions UNIQUE_USERS() and GROUP_UNIQUE_USERS().
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index cf4f90d99c9..a4fbaeafaa7 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -51,7 +51,7 @@ sqlsources = derror.cc field.cc field_conv.cc strfunc.cc filesort.cc \
hostname.cc init.cc password.c \
item.cc item_buff.cc item_cmpfunc.cc item_create.cc \
item_func.cc item_strfunc.cc item_sum.cc item_timefunc.cc \
- item_geofunc.cc item_uniq.cc item_subselect.cc item_row.cc\
+ item_geofunc.cc item_subselect.cc item_row.cc\
item_xmlfunc.cc \
key.cc lock.cc log.cc log_event.cc sql_state.c \
protocol.cc net_serv.cc opt_range.cc \