summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authorunknown <tomas@whalegate.ndb.mysql.com>2007-04-16 14:51:55 +0200
committerunknown <tomas@whalegate.ndb.mysql.com>2007-04-16 14:51:55 +0200
commit15a2bbd3cab194baa898116b14dbd369810a25ff (patch)
tree3ee4674c5f5e205b8b079d50f0baa63c5769f785 /libmysqld/Makefile.am
parented024c024d0f7d0e392752a426eacb3b697bc829 (diff)
parent8a4f717dfe87219281be020cc8d5f11f16d9e8f4 (diff)
downloadmariadb-git-15a2bbd3cab194baa898116b14dbd369810a25ff.tar.gz
Merge whalegate.ndb.mysql.com:/home/tomas/mysql-5.1-single-user
into whalegate.ndb.mysql.com:/home/tomas/mysql-5.1-new-maint BitKeeper/etc/ignore: auto-union BitKeeper/deleted/.del-configure.in.rej: Auto merged configure.in: Auto merged sql/item.h: Auto merged sql/sql_select.cc: Auto merged
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index 83796fad6d3..48981e4beee 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -177,11 +177,11 @@ endif
#libmysqld_la_LDFLAGS = -version-info @SHARED_LIB_VERSION@
#CLEANFILES = $(libmysqld_la_LIBADD) libmysqld.la
-# This is called from the toplevel makefile. If we can link now
-# to an existing file in source, we do that, else we assume it
-# will show up in the build tree eventually (generated file).
+BUILT_SOURCES = link_sources
+
+CLEANFILES = $(BUILT_SOURCES)
+
link_sources:
- set -x; \
for f in $(sqlsources); do \
rm -f $$f; \
if test -e $(top_srcdir)/sql/$$f ; \
@@ -215,12 +215,13 @@ link_sources:
done; \
fi; \
rm -f client_settings.h; \
- @LN_CP_F@ $(top_srcdir)/libmysql/client_settings.h client_settings.h
+ @LN_CP_F@ $(top_srcdir)/libmysql/client_settings.h \
+ client_settings.h; \
+ echo timestamp > link_sources
clean-local:
- rm -f `echo $(sqlsources) $(libmysqlsources) $(sqlstoragesources) $(storagesources) | sed "s;\.lo;.c;g"` \
- $(top_srcdir)/linked_libmysqld_sources; \
+ rm -f `echo $(sqlsources) $(libmysqlsources) $(sqlstoragesources) $(storagesources) | sed "s;\.lo;.c;g"`; \
rm -f client_settings.h
# Don't update the files from bitkeeper