summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authormsvensson@pilot.blaudden <>2007-03-27 23:56:48 +0200
committermsvensson@pilot.blaudden <>2007-03-27 23:56:48 +0200
commitb554258a8e453539d87a1a0a572b4d329b58d9eb (patch)
tree02a7e0d66c1854e1350626ab89132b36162066bd /libmysqld/Makefile.am
parent764d84852ef83c3584ca1e03bebd34b1b29d1f53 (diff)
downloadmariadb-git-b554258a8e453539d87a1a0a572b4d329b58d9eb.tar.gz
Bug#22508 BUILD/compile-dist fails due to problem with readline/libedit
- Move the link_sources command from top level Makefile into each subdir that need to link files
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index 0f57d01108c..0f49acfc8c5 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -176,11 +176,11 @@ endif
#libmysqld_la_LDFLAGS = -version-info @SHARED_LIB_VERSION@
#CLEANFILES = $(libmysqld_la_LIBADD) libmysqld.la
-# This is called from the toplevel makefile. If we can link now
-# to an existing file in source, we do that, else we assume it
-# will show up in the build tree eventually (generated file).
+BUILT_SOURCES = link_sources
+
+CLEANFILES = $(BUILT_SOURCES)
+
link_sources:
- set -x; \
for f in $(sqlsources); do \
rm -f $$f; \
if test -e $(top_srcdir)/sql/$$f ; \
@@ -214,12 +214,13 @@ link_sources:
done; \
fi; \
rm -f client_settings.h; \
- @LN_CP_F@ $(top_srcdir)/libmysql/client_settings.h client_settings.h
+ @LN_CP_F@ $(top_srcdir)/libmysql/client_settings.h \
+ client_settings.h; \
+ echo timestamp > link_sources
clean-local:
- rm -f `echo $(sqlsources) $(libmysqlsources) $(sqlstoragesources) $(storagesources) | sed "s;\.lo;.c;g"` \
- $(top_srcdir)/linked_libmysqld_sources; \
+ rm -f `echo $(sqlsources) $(libmysqlsources) $(sqlstoragesources) $(storagesources) | sed "s;\.lo;.c;g"`; \
rm -f client_settings.h
# Don't update the files from bitkeeper