summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authorunknown <tim@black.box>2001-08-10 12:37:36 -0400
committerunknown <tim@black.box>2001-08-10 12:37:36 -0400
commitb538ff90dad25d5975b68182bd064bc7a95ebfc2 (patch)
tree0b1bf2d0aed5c3d69b112448bb146dcc526f9890 /libmysqld/Makefile.am
parent4bb40187438bdfb8b1d8b091399bd01e0e3425c1 (diff)
downloadmariadb-git-b538ff90dad25d5975b68182bd064bc7a95ebfc2.tar.gz
Embedded mysql fixes.
There is now a mysql_server_init() function which needs to be called at the beginning of the program (and _end() for the end of the program). This routine handles argument parsing for the embedded server. Use the embedded version of mysql_load_file() (ignore the LOCAL argument, since the client and server are the same program). There are now mysql_thread_init/end() functions for the client to use in a multi-threaded app. They are just wrappers for my_thread_init/end(). BitKeeper/deleted/.del-README~434e9cae5fa9a4c4: Delete: libmysqld/README libmysqld/lib_load.cc: minor cleanup include/mysql.h: add mysql_server/thread_init/end() libmysql/libmysql.c: add mysql_server/thread_init/end() libmysqld/lib_sql.cc: add mysql_server/thread_init/end() libmysqld/libmysqld.c: add mysql_server/thread_init/end() sql/mysqld.cc: allow get_options() to be called more than once libmysqld/Makefile.am: use lib_load.cc instead of sql_load.cc BitKeeper/etc/logging_ok: Logging to logging@openlogging.org accepted
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index d19029e31f6..02d2d007b5d 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -33,7 +33,7 @@ INCLUDES = @MT_INCLUDES@ @bdb_includes@ -I$(srcdir)/../include -I../include \
LDADD = @CLIENT_EXTRA_LDFLAGS@ libmysqld.la
pkglib_LTLIBRARIES = libmysqld.la
-libmysqld_la_SOURCES = libmysqld.c lib_sql.cc
+libmysqld_la_SOURCES = libmysqld.c lib_sql.cc lib_load.cc
libmysqlsources = errmsg.c get_password.c password.c
## XXX: we should not have to duplicate info from the sources list
@@ -50,7 +50,7 @@ sqlsources = convert.cc derror.cc field.cc field_conv.cc filesort.cc \
opt_sum.cc procedure.cc records.cc slave.cc sql_acl.cc \
sql_analyse.cc sql_base.cc sql_cache.cc sql_class.cc \
sql_crypt.cc sql_db.cc sql_delete.cc sql_insert.cc sql_lex.cc \
- sql_list.cc sql_load.cc sql_manager.cc sql_map.cc sql_parse.cc \
+ sql_list.cc sql_manager.cc sql_map.cc sql_parse.cc \
sql_rename.cc sql_repl.cc sql_select.cc sql_show.cc \
sql_string.cc sql_table.cc sql_test.cc sql_udf.cc \
sql_update.cc sql_yacc.cc table.cc thr_malloc.cc time.cc \
@@ -68,7 +68,7 @@ sqlobjects = convert.lo derror.lo field.lo field_conv.lo filesort.lo \
opt_sum.lo procedure.lo records.lo slave.lo sql_acl.lo \
sql_analyse.lo sql_base.lo sql_cache.lo sql_class.lo \
sql_crypt.lo sql_db.lo sql_delete.lo sql_insert.lo sql_lex.lo \
- sql_list.lo sql_load.lo sql_manager.lo sql_map.lo sql_parse.lo \
+ sql_list.lo sql_manager.lo sql_map.lo sql_parse.lo \
sql_rename.lo sql_repl.lo sql_select.lo sql_show.lo \
sql_string.lo sql_table.lo sql_test.lo sql_udf.lo \
sql_update.lo sql_yacc.lo table.lo thr_malloc.lo time.lo \