summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authorunknown <brian@zim.(none)>2005-12-22 01:07:47 -0800
committerunknown <brian@zim.(none)>2005-12-22 01:07:47 -0800
commit67c96c78f5c91ca83c97280de48c572a251578d6 (patch)
tree514a9b15f4759bd8dc2e68f54e9ace6111254ba2 /libmysqld/Makefile.am
parentec6121fb40519f75e5a6e5b2a77025db6f7b14c9 (diff)
downloadmariadb-git-67c96c78f5c91ca83c97280de48c572a251578d6.tar.gz
This patch does the following:
1) Fixes breakage in embedded server build for XMLPath push. 2) Hides PARTITION engine from view. 3) Add ENGINES information schema (and it should now be clear from this patch on how to turn any show command into an information schema). libmysqld/Makefile.am: Fix for embedded server to build. mysql-test/r/information_schema.result: Fix for additional information_schema mysql-test/r/information_schema_db.result: Fix for adding additional engines information schema. mysql-test/t/information_schema.test: Added test to make sure that engines information schema works. sql/ha_partition.cc: Made PARTITION hidden in information schema. sql/sql_parse.cc: Added additional case for engine information schema. sql/sql_show.cc: Code for ENGINES information schema. sql/sql_yacc.yy: Extended grammer to support new ENGINES information schema sql/table.h: Comment on dependency in information schema. libmysqld/item_xmlfunc.cc: New BitKeeper file ``libmysqld/item_xmlfunc.cc''
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index 12531a553eb..fb34b3a2bca 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -64,6 +64,7 @@ sqlsources = derror.cc field.cc field_conv.cc strfunc.cc filesort.cc \
spatial.cc gstream.cc sql_help.cc tztime.cc sql_cursor.cc \
sp_head.cc sp_pcontext.cc sp.cc sp_cache.cc sp_rcontext.cc \
parse_file.cc sql_view.cc sql_trigger.cc my_decimal.cc \
+ item_xmlfunc.cc \
rpl_filter.cc sql_partition.cc handlerton.cc sql_plugin.cc
libmysqld_int_a_SOURCES= $(libmysqld_sources) $(libmysqlsources) $(sqlsources)