summaryrefslogtreecommitdiff
path: root/libmysqld/Makefile.am
diff options
context:
space:
mode:
authoranozdrin@mysql.com <>2006-01-11 02:07:40 +0300
committeranozdrin@mysql.com <>2006-01-11 02:07:40 +0300
commitb04b851ef9540e14641db9e5ee6c5a572b8119fb (patch)
tree2d2fbf7237a87334eb708a2f4af55c8b443046df /libmysqld/Makefile.am
parentcdf3e4c02e12d4d2de697e7237a8d1fa72a9b0ac (diff)
downloadmariadb-git-b04b851ef9540e14641db9e5ee6c5a572b8119fb.tar.gz
Fix for BUG#15110: mysqldump --triggers: does not include DEFINER clause
There are two main idea of this fix: - introduce a common function for server and client to split user value (<user name>@<host name>) into user name and host name parts; - dump DEFINER clause in correct format in mysqldump.
Diffstat (limited to 'libmysqld/Makefile.am')
-rw-r--r--libmysqld/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/libmysqld/Makefile.am b/libmysqld/Makefile.am
index f07bbacba02..5ec9cdfe5bf 100644
--- a/libmysqld/Makefile.am
+++ b/libmysqld/Makefile.am
@@ -63,7 +63,7 @@ sqlsources = derror.cc field.cc field_conv.cc strfunc.cc filesort.cc \
spatial.cc gstream.cc sql_help.cc tztime.cc sql_cursor.cc \
sp_head.cc sp_pcontext.cc sp.cc sp_cache.cc sp_rcontext.cc \
parse_file.cc sql_view.cc sql_trigger.cc my_decimal.cc \
- ha_blackhole.cc ha_archive.cc
+ ha_blackhole.cc ha_archive.cc my_user.c
libmysqld_int_a_SOURCES= $(libmysqld_sources) $(libmysqlsources) $(sqlsources) $(sqlexamplessources)
libmysqld_a_SOURCES=