summaryrefslogtreecommitdiff
path: root/libmysqld/examples/Makefile.am
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2003-09-12 12:42:34 +0200
committerunknown <lenz@mysql.com>2003-09-12 12:42:34 +0200
commitf61743dea88b0581a12a0f1db673ea3ef3e699c5 (patch)
treeaa764437ec69be153252826ff2bde43aaa638f93 /libmysqld/examples/Makefile.am
parent4d2d0eb5d8b39c3d892b3ca365497aa4a16115e1 (diff)
downloadmariadb-git-f61743dea88b0581a12a0f1db673ea3ef3e699c5.tar.gz
Portability fixes:
- removed "-traditional-cpp" from the darwin6 compile flags, as it broke compilation with gcc-3.3 on Mac OS X and does not seem to be required in general. - make sure to link libmysqld/examples/mysqltest.c with a C++ compiler, as the embedded server library (libmysqld.a) includes C++ code. This broke compilation with non-gcc compilers. configure.in: - removed "-traditional-cpp" from the darwin6 compile flags, as it broke compilation with gcc-3.3 and does not seem to be required in general. libmysqld/examples/Makefile.am: - make sure to link mysqltest.c with a C++ compiler, as the embedded server library (libmysqld.a) includes C++ code.
Diffstat (limited to 'libmysqld/examples/Makefile.am')
-rw-r--r--libmysqld/examples/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/libmysqld/examples/Makefile.am b/libmysqld/examples/Makefile.am
index f741ddf0191..61f54b88b2e 100644
--- a/libmysqld/examples/Makefile.am
+++ b/libmysqld/examples/Makefile.am
@@ -13,6 +13,8 @@ INCLUDES = @MT_INCLUDES@ -I$(top_srcdir)/include -I$(srcdir) \
LIBS = @LIBS@ @WRAPLIBS@
LDADD = @CLIENT_EXTRA_LDFLAGS@ ../libmysqld.a @innodb_system_libs@ @LIBDL@ $(CXXLDFLAGS)
+mysqltest_LINK = $(CXXLINK)
+
mysqltest_SOURCES = mysqltest.c
mysql_SOURCES = mysql.cc readline.cc completion_hash.cc \