summaryrefslogtreecommitdiff
path: root/libmysqld/examples/Makefile.am
diff options
context:
space:
mode:
authorunknown <kent@mysql.com>2005-09-24 15:51:45 +0200
committerunknown <kent@mysql.com>2005-09-24 15:51:45 +0200
commit5409f2554f7b1bfc7c736c16b0ebef5668883909 (patch)
treef0bf9c7e18d71c6b6363b180d52a8c4463736bc9 /libmysqld/examples/Makefile.am
parentb337566babce87b4a5854f18586206525a4ba1b7 (diff)
downloadmariadb-git-5409f2554f7b1bfc7c736c16b0ebef5668883909.tar.gz
Makefile.am, configure.in:
Enable "make distcheck" to work configure.in: Enable "make distcheck" to work Docs/Makefile.am: Enable "make distcheck" to work Makefile.am: Enable "make distcheck" to work client/Makefile.am: Enable "make distcheck" to work cmd-line-utils/libedit/Makefile.am: Enable "make distcheck" to work include/Makefile.am: Enable "make distcheck" to work libmysql/Makefile.am: Enable "make distcheck" to work libmysql_r/Makefile.am: Enable "make distcheck" to work libmysqld/Makefile.am: Enable "make distcheck" to work libmysqld/examples/Makefile.am: Enable "make distcheck" to work mysql-test/Makefile.am: Enable "make distcheck" to work ndb/docs/Makefile.am: Enable "make distcheck" to work netware/Makefile.am: Enable "make distcheck" to work pstack/Makefile.am: Enable "make distcheck" to work scripts/Makefile.am: Enable "make distcheck" to work sql-bench/Makefile.am: Enable "make distcheck" to work sql/Makefile.am: Enable "make distcheck" to work sql/share/Makefile.am: Enable "make distcheck" to work support-files/Makefile.am: Enable "make distcheck" to work
Diffstat (limited to 'libmysqld/examples/Makefile.am')
-rw-r--r--libmysqld/examples/Makefile.am15
1 files changed, 8 insertions, 7 deletions
diff --git a/libmysqld/examples/Makefile.am b/libmysqld/examples/Makefile.am
index d19023c100f..588a6153a3b 100644
--- a/libmysqld/examples/Makefile.am
+++ b/libmysqld/examples/Makefile.am
@@ -20,14 +20,15 @@ client_sources = $(mysqltest_embedded_SOURCES) $(mysql_SOURCES)
tests_sources= $(mysql_client_test_embedded_SOURCES)
link_sources:
+ set -x; \
for f in $(client_sources); do \
- rm -f $(srcdir)/$$f; \
- @LN_CP_F@ $(srcdir)/../../client/$$f $(srcdir)/$$f; \
- done;
+ rm -f $$f; \
+ @LN_CP_F@ $(top_srcdir)/client/$$f $$f; \
+ done; \
for f in $(tests_sources); do \
- rm -f $(srcdir)/$$f; \
- @LN_CP_F@ $(srcdir)/../../tests/$$f $(srcdir)/$$f; \
- done;
+ rm -f $$f; \
+ @LN_CP_F@ $(top_srcdir)/tests/$$f $$f; \
+ done
DEFS = -DEMBEDDED_LIBRARY
INCLUDES = @MT_INCLUDES@ \
@@ -48,7 +49,7 @@ mysql_LDADD = @readline_link@ @TERMCAP_LIB@ $(LDADD)
mysql_client_test_embedded_LINK = $(CXXLINK)
mysql_client_test_embedded_SOURCES = mysql_client_test.c
-clean:
+clean-local:
rm -f $(client_sources)
rm -f $(tests_sources)