summaryrefslogtreecommitdiff
path: root/libservices/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Botchkov <holyfoot@askmonty.org>2012-03-14 00:55:56 +0400
committerAlexey Botchkov <holyfoot@askmonty.org>2012-03-14 00:55:56 +0400
commit07a82c58a7306bd8ef889dd912cdc437a9f83a89 (patch)
treeedd7edc02e96ad32d8f7d8d5137db548562be16e /libservices/CMakeLists.txt
parent92f31d8070738206c5b64d3ab5cc9a0cb05c56fa (diff)
downloadmariadb-git-07a82c58a7306bd8ef889dd912cdc437a9f83a89.tar.gz
MDEV-15 Log all SQL errors.
Added the logger service that provides us with the rotating logs. The plugin SQL_ERROR_LOG added. It logs the errors using the 'logger service' for the rotating log files. the example record from the log: 2012-03-09 15:07:29 root[root] @ localhost [] ERROR 1146: Table 'test.xyz' doesn't exist : select * from test.xyz
Diffstat (limited to 'libservices/CMakeLists.txt')
-rw-r--r--libservices/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/libservices/CMakeLists.txt b/libservices/CMakeLists.txt
index ee6a7c73abe..dd16558ef9c 100644
--- a/libservices/CMakeLists.txt
+++ b/libservices/CMakeLists.txt
@@ -20,7 +20,8 @@ SET(MYSQLSERVICES_SOURCES
thd_alloc_service.c
thd_wait_service.c
my_thread_scheduler_service.c
- progress_report_service.c)
+ progress_report_service.c
+ logger_service.c)
ADD_CONVENIENCE_LIBRARY(mysqlservices ${MYSQLSERVICES_SOURCES})
INSTALL(TARGETS mysqlservices DESTINATION ${INSTALL_LIBDIR} COMPONENT Development)