summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorlenz@mysql.com <>2004-01-20 17:14:02 +0100
committerlenz@mysql.com <>2004-01-20 17:14:02 +0100
commit8032d6df4e8a1691b57ed18e3a0e221ed7874341 (patch)
tree627e2ebc8c0a3f144a00460986beef6696124786 /man/Makefile.am
parent56e8554aac6528f3bec4d8d866faa9728acdb90a (diff)
downloadmariadb-git-8032d6df4e8a1691b57ed18e3a0e221ed7874341.tar.gz
What started as an attempt to fix BUG#2270 (Substitute paths in mysql
manpage) turned out as a major overhaul of all man pages: - renamed all *.1 files to *.1.in to act as templates which are being processed at build time - replaced some hard-coded values with place holder that are being replaced with the proper values at build time - Updated list of available man pages in the SEE ALSO section and added a hint to the manual for more details - Added a BUGS section to all pages, referring to the bugs DB - Updated some obsolete URLs and mail addresses The actual content of these man pages should probably be cross-checked for correctness, though...
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 9f919e77b8f..37eb8a13f4e 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -21,7 +21,26 @@ man_MANS = mysql.1 isamchk.1 isamlog.1 mysql_zap.1 mysqlaccess.1 \
mysqladmin.1 mysqld.1 mysqld_multi.1 mysqldump.1 mysqlshow.1 \
perror.1 replace.1 mysqld_safe.1 mysql_fix_privilege_tables.1
-EXTRA_DIST = $(man_MANS)
+EXTRA_DIST = mysql.1.in isamchk.1.in isamlog.1.in mysql_zap.1.in \
+ mysqlaccess.1.in mysqladmin.1.in mysqld.1.in mysqld_multi.1.in \
+ mysqldump.1.in mysqlshow.1.in perror.1.in replace.1.in \
+ mysqld_safe.1.in mysql_fix_privilege_tables.1.in
+
+CLEANFILES = $(man_MANS)
+
+SUFFIXES = .in
+
+.in:
+ @RM@ -f $@ $@-t
+ @SED@ \
+ -e 's!@''MYSQL_BASE_VERSION''@!@MYSQL_BASE_VERSION@!' \
+ -e 's!@''sysconfdir''@!@sysconfdir@!' \
+ -e 's!@''bindir''@!$(bindir)!g' \
+ -e 's!@''libexecdir''@!$(libexecdir)!g' \
+ -e 's!@''localstatedir''@!$(localstatedir)!g' \
+ -e 's!@''MYSQL_NO_DASH_VERSION''@!@MYSQL_NO_DASH_VERSION@!' \
+ $< > $@-t
+ @MV@ $@-t $@
# Don't update the files from bitkeeper
%::SCCS/s.%