summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorunknown <lenz@mysql.com>2004-01-20 17:14:02 +0100
committerunknown <lenz@mysql.com>2004-01-20 17:14:02 +0100
commitefa80e01a4ca410723dd8bf185e84e4d6ed02359 (patch)
tree627e2ebc8c0a3f144a00460986beef6696124786 /man/Makefile.am
parent36d82d189a258989a3c4cfdecc2011e240f65cdb (diff)
downloadmariadb-git-efa80e01a4ca410723dd8bf185e84e4d6ed02359.tar.gz
What started as an attempt to fix BUG#2270 (Substitute paths in mysql
manpage) turned out as a major overhaul of all man pages: - renamed all *.1 files to *.1.in to act as templates which are being processed at build time - replaced some hard-coded values with place holder that are being replaced with the proper values at build time - Updated list of available man pages in the SEE ALSO section and added a hint to the manual for more details - Added a BUGS section to all pages, referring to the bugs DB - Updated some obsolete URLs and mail addresses The actual content of these man pages should probably be cross-checked for correctness, though... man/Makefile.am: - Replace some hard-coded values in the man pages with the proper values at build time instead. Instead of the *.1 files, we now add the *.1.in files (the templates) to the source distribution and generate the *.1 files during make. man/isamchk.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/isamlog.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysql_fix_privilege_tables.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysql_zap.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysqlaccess.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysqladmin.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysqld.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysqld_multi.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysqld_safe.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysqldump.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysqlshow.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/perror.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/replace.1.in: - replaced some hard-coded values (e.g. Version numbers) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address man/mysql.1.in: - replaced some hard-coded values (e.g. Version numbers, path names) with variables which are replaced with the proper values at build time - Updated list of other man pages listed in SEE ALSO - Added BUGS section, referring to the bugs database - Updated URL and Mail address
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am21
1 files changed, 20 insertions, 1 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 9f919e77b8f..37eb8a13f4e 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -21,7 +21,26 @@ man_MANS = mysql.1 isamchk.1 isamlog.1 mysql_zap.1 mysqlaccess.1 \
mysqladmin.1 mysqld.1 mysqld_multi.1 mysqldump.1 mysqlshow.1 \
perror.1 replace.1 mysqld_safe.1 mysql_fix_privilege_tables.1
-EXTRA_DIST = $(man_MANS)
+EXTRA_DIST = mysql.1.in isamchk.1.in isamlog.1.in mysql_zap.1.in \
+ mysqlaccess.1.in mysqladmin.1.in mysqld.1.in mysqld_multi.1.in \
+ mysqldump.1.in mysqlshow.1.in perror.1.in replace.1.in \
+ mysqld_safe.1.in mysql_fix_privilege_tables.1.in
+
+CLEANFILES = $(man_MANS)
+
+SUFFIXES = .in
+
+.in:
+ @RM@ -f $@ $@-t
+ @SED@ \
+ -e 's!@''MYSQL_BASE_VERSION''@!@MYSQL_BASE_VERSION@!' \
+ -e 's!@''sysconfdir''@!@sysconfdir@!' \
+ -e 's!@''bindir''@!$(bindir)!g' \
+ -e 's!@''libexecdir''@!$(libexecdir)!g' \
+ -e 's!@''localstatedir''@!$(localstatedir)!g' \
+ -e 's!@''MYSQL_NO_DASH_VERSION''@!@MYSQL_NO_DASH_VERSION@!' \
+ $< > $@-t
+ @MV@ $@-t $@
# Don't update the files from bitkeeper
%::SCCS/s.%