summaryrefslogtreecommitdiff
path: root/mysql-test/CMakeLists.txt
diff options
context:
space:
mode:
authorSergei Golubchik <serg@mariadb.org>2017-08-15 01:11:37 +0200
committerSergei Golubchik <serg@mariadb.org>2017-08-15 09:47:03 +0200
commitc724fcd7a0d6bc3ec725bc8b5a40e5cfc771eb56 (patch)
treef0ef74fa742f25b2e52584b31fa7edf5184bb26d /mysql-test/CMakeLists.txt
parent88879b37fc97a5f7015422a0571071067436add6 (diff)
downloadmariadb-git-c724fcd7a0d6bc3ec725bc8b5a40e5cfc771eb56.tar.gz
MDEV-13525 mtr and mysql-test-run symlinks are not installed anymore
Install mtr and mysql-test-run symlinks in case of the out-of-source build. This was broken in c872b10022
Diffstat (limited to 'mysql-test/CMakeLists.txt')
-rw-r--r--mysql-test/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index 996dacff319..7e5ef3fb8df 100644
--- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt
@@ -22,6 +22,7 @@ IF(NOT ${CMAKE_SOURCE_DIR} STREQUAL ${CMAKE_BINARY_DIR})
${CMAKE_CURRENT_BINARY_DIR}/mysql-test-run.pl
@ONLY
)
+ SET(out_of_source_build TRUE)
ENDIF()
IF(UNIX)
EXECUTE_PROCESS(
@@ -32,6 +33,12 @@ IF(UNIX)
./mysql-test-run.pl mysql-test-run
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)
+ IF(INSTALL_MYSQLTESTDIR AND out_of_source_build)
+ INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mtr
+ ${CMAKE_CURRENT_BINARY_DIR}/mysql-test-run
+ DESTINATION ${INSTALL_MYSQLTESTDIR}
+ COMPONENT Test)
+ ENDIF()
ENDIF()
IF(CMAKE_GENERATOR MATCHES "Visual Studio")