summaryrefslogtreecommitdiff
path: root/mysql-test/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-03-17 19:56:22 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-03-17 19:56:22 +0100
commitc8e32a8331f5c658647e5c0aa480adbb9a059f7c (patch)
tree2d7936920bf092e313f7acff9b9c014bc576da0e /mysql-test/CMakeLists.txt
parent9c1918a7f700c50fd911726b2d092f33b24792a6 (diff)
downloadmariadb-git-c8e32a8331f5c658647e5c0aa480adbb9a059f7c.tar.gz
Bug #52149 - packaging differences in CMake build
Corrected some packaging bugs: - install mysqlservices library - install libmysqlclient_r.so.{16,16.0.0} as links to libmysqlclient.so - install libmysqld-debug.a - install my_safe_process, my_safe_kill and symlinks to mysql-test-run.pl (mtr, mysql-test-run) into correct place ${INSTALL_MYSQLTESTDIR} cmake/install_layout.cmake: Fix typo cmake/install_macros.cmake: Refactor INSTALL_SYMLINK to allow arbitrary symlink paths. Old version of this macro would make link extension the same as in target. This was not sufficient in some scenarios (would not allow for example libmysqlclient_r.so.16=>./libmysqlclient.so link) libmysql/CMakeLists.txt: Install extra symlinks to libmysqlclient.so (libmysqlclient_r.so.16 and libmysqlclient_r.so.16.0.0) for backward compatiblity. libmysqld/CMakeLists.txt: install libmysqld-debug.a libservices/CMakeLists.txt: install mysqlservices library mysql-test/lib/My/SafeProcess/CMakeLists.txt: install my_safe_process, my_safe_kill into correct place
Diffstat (limited to 'mysql-test/CMakeLists.txt')
-rw-r--r--mysql-test/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index 2cc65a9c82f..b8b7d08135f 100644
--- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt
@@ -46,7 +46,8 @@ IF(UNIX)
WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
)
INSTALL(FILES ${CMAKE_CURRENT_BINARY_DIR}/mtr
- ${CMAKE_CURRENT_BINARY_DIR}/mysql-test-run DESTINATION mysql-test)
+ ${CMAKE_CURRENT_BINARY_DIR}/mysql-test-run
+ DESTINATION ${INSTALL_MYSQLTESTDIR})
ENDIF()
IF(CMAKE_GENERATOR MATCHES "Visual Studio")