summaryrefslogtreecommitdiff
path: root/mysql-test/CMakeLists.txt
diff options
context:
space:
mode:
authorVladislav Vaintroub <vvaintroub@mysql.com>2010-03-03 12:29:34 +0100
committerVladislav Vaintroub <vvaintroub@mysql.com>2010-03-03 12:29:34 +0100
commitcd03a4625fbf481deeb6c32c8cb6ff74d900098b (patch)
treecb883ffd7d056d99712bf0a248cbb068e96287d5 /mysql-test/CMakeLists.txt
parent0139908c7ebcec8b40255c5d38c8c2583ed0f1c1 (diff)
downloadmariadb-git-cd03a4625fbf481deeb6c32c8cb6ff74d900098b.tar.gz
Bug #51488 :missing features and change behavior in cmake runs compared to
autotools runs - Fix recognition of --with-debug=full in configure wrapper - Remove CMakeCache.txt in configure wrapper, to match the original - Fix recognition of max-no-ndb - Fix broken dependencies of mysql_fix_privilege_table.sql from mysql_system_tables.sql and mysql_system_tables_fix.sql - Add "distclean target" that informs user about appropriate bzr command cmake/configure.pl: - Recognize --with-debug=full, map to WITH_DEBUG_FULL - remove CMakeCache.txt, so the configuration is no more sticky (to match the original configure behavior) cmake/plugin.cmake: - Recognize WITH_MAX_NO_NDB, this fixes missing storage engines after BUILD/*max-no-ndb scripts mysql-test/CMakeLists.txt: test-force uses the same macros (MTR_FORCE) as test-bt* now scripts/CMakeLists.txt: - Fix broken dependency when producing mysql_fix_privilege_tables.sql, reported by Davi. We now concatenate 2 scripts in custom command that has dependency on both scripts rather than concatenating them at cmake time. sql/CMakeLists.txt: Address frequently asked question "where is distclean" by implementing distclean target that does nothing except pointing to appropriate bzr command. It is better not to call "bzr clean-tree" automatically, without user consent. It could clean new files that were meant to be added.
Diffstat (limited to 'mysql-test/CMakeLists.txt')
-rw-r--r--mysql-test/CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/mysql-test/CMakeLists.txt b/mysql-test/CMakeLists.txt
index 794f286ac56..2cc65a9c82f 100644
--- a/mysql-test/CMakeLists.txt
+++ b/mysql-test/CMakeLists.txt
@@ -64,12 +64,6 @@ ELSE()
ENDIF()
-ADD_CUSTOM_TARGET(test-force
- COMMAND ${SETCONFIG_COMMAND}
- COMMAND ${SETOS_COMMAND}
- COMMAND perl mysql-test-run.pl --force
- WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
-)
SET(EXP --experimental=collections/default.experimental)
IF(WIN32)
@@ -100,6 +94,11 @@ SET(TEST_BT_START
COMMAND ${SET_ENV} MTR_BUILD_THREAD=auto
)
+ADD_CUSTOM_TARGET(test-force
+ ${TEST_BT_START}
+ COMMAND ${MTR_FORCE}
+)
+
ADD_CUSTOM_TARGET(test-bt
${TEST_BT_START}
COMMAND ${MTR_FORCE} --comment=normal --timer --skip-ndbcluster --report-features ${EXP}
@@ -124,4 +123,3 @@ ADD_CUSTOM_TARGET(test-bt-debug
COMMAND ${MTR_FORCE} --comment=debug --timer --skip-ndbcluster --skip-rpl --report-features ${EXP}
)
-