summaryrefslogtreecommitdiff
path: root/mysql-test/Makefile.am
diff options
context:
space:
mode:
authorunknown <msvensson@pilot.blaudden>2007-02-28 15:03:47 +0100
committerunknown <msvensson@pilot.blaudden>2007-02-28 15:03:47 +0100
commit22cac737ca87dc9f2e58069f21066c88d57a3e2c (patch)
tree441ee3151ef2154f0d6c80a45083b3136a3a3cd8 /mysql-test/Makefile.am
parent7624028419147d656646c95b2bc11ea72aa3e419 (diff)
downloadmariadb-git-22cac737ca87dc9f2e58069f21066c88d57a3e2c.tar.gz
Bug#20166 mysql-test-run.pl does not test system privilege tables creation
- Build lib/init-db.sql from the output of mysql_create_system_tables - Remove mysql-test/init_db.sql and mysql-test/lib/init_db.sql - Leave netware/init_db.sql until 5.0 where we should soon have possibility to test with mysql-test-run.pl BitKeeper/deleted/.del-init_db.sql: Delete: mysql-test/init_db.sql BitKeeper/deleted/.del-init_db.sql~a77d572c39d5a1f8: Delete: mysql-test/lib/init_db.sql BitKeeper/etc/ignore: Added mysql-test/lib/init_db.sql to the ignore list mysql-test/Makefile.am: Build lib/init_db.sql from the output of mysql_create_system_tables
Diffstat (limited to 'mysql-test/Makefile.am')
-rw-r--r--mysql-test/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/mysql-test/Makefile.am b/mysql-test/Makefile.am
index 5b0a8afe98e..02a1a801d36 100644
--- a/mysql-test/Makefile.am
+++ b/mysql-test/Makefile.am
@@ -35,7 +35,7 @@ testdir = $(benchdir_root)/mysql-test
EXTRA_SCRIPTS = mysql-test-run-shell.sh install_test_db.sh \
valgrind.supp $(PRESCRIPTS)
EXTRA_DIST = $(EXTRA_SCRIPTS)
-GENSCRIPTS = mysql-test-run-shell mysql-test-run install_test_db mtr
+GENSCRIPTS = mysql-test-run-shell mysql-test-run install_test_db mtr lib/init_db.sql
PRESCRIPTS = mysql-test-run.pl
test_SCRIPTS = $(GENSCRIPTS) $(PRESCRIPTS)
test_DATA = std_data/client-key.pem \
@@ -119,6 +119,11 @@ mysql-test-run:
$(RM) -f mysql-test-run
$(LN_S) mysql-test-run.pl mysql-test-run
+# Build init_db.sql by executing mysql_create_system_tables
+lib/init_db.sql:
+ $(top_builddir)/scripts/mysql_create_system_tables \
+ test . \@HOSTNAME\@ > lib/init_db.sql
+
SUFFIXES = .sh
.sh: