summaryrefslogtreecommitdiff
path: root/mysql-test/Makefile.am
diff options
context:
space:
mode:
authormonty@donna.mysql.com <>2001-01-02 14:29:47 +0200
committermonty@donna.mysql.com <>2001-01-02 14:29:47 +0200
commite9c2f7d4393075d16da0ae18a9576bebcb1e0dda (patch)
tree06f19c5186e8abb542c18b22202664c033b53f4f /mysql-test/Makefile.am
parent476d960b4246884f74a22fec0d8cd2ff0f280960 (diff)
downloadmariadb-git-e9c2f7d4393075d16da0ae18a9576bebcb1e0dda.tar.gz
Fixes to get mysql-test included in the distributions
Diffstat (limited to 'mysql-test/Makefile.am')
-rw-r--r--mysql-test/Makefile.am13
1 files changed, 7 insertions, 6 deletions
diff --git a/mysql-test/Makefile.am b/mysql-test/Makefile.am
index 88f55690651..20522da3b50 100644
--- a/mysql-test/Makefile.am
+++ b/mysql-test/Makefile.am
@@ -17,11 +17,12 @@
## Process this file with automake to create Makefile.in
-EXTRA_SCRIPTS = mysql-test-run.sh install_test_db.sh
-EXTRA_DIST = $(EXTRA_SCRIPTS)
-testdir = $(prefix)/mysql-test
-test_SCRIPTS = mysql-test-run install_test_db
-CLEANFILES = $(test_SCRIPTS)
+benchdir_root= $(prefix)
+testdir = $(benchdir_root)/mysql-test
+EXTRA_SCRIPTS = mysql-test-run.sh install_test_db.sh
+EXTRA_DIST = $(EXTRA_SCRIPTS)
+test_SCRIPTS = mysql-test-run install_test_db
+CLEANFILES = $(test_SCRIPTS)
dist-hook:
mkdir -p $(distdir)/t $(distdir)/r $(distdir)/include \
@@ -52,7 +53,7 @@ SUFFIXES = .sh
.sh:
@RM@ -f $@ $@-t
@SED@ \
- -e 's!@''benchdir''@!$(benchdir)!g' \
+ -e 's!@''testdir''@!$(testdir)!g' \
-e 's!@''bindir''@!$(bindir)!g' \
-e 's!@''scriptdir''@!$(bindir)!g' \
-e 's!@''prefix''@!$(prefix)!g' \